Go Down

Topic: Arduino Micro + MFRC522 : Problème avec le 3.3V (Read 300 times) previous topic - next topic

Electrof

Jul 10, 2018, 11:19 am Last Edit: Jul 10, 2018, 11:23 am by Electrof
Bonjour,

C'est mon 1er message dans ce forum, et j'espère que ca ne sera pas le dernier  :)
Alors, avant toute chose, dans les hypothèses structurantes à savoir, je débute tout juste l'Arduino et l'électronique, mais c'est une domaine qui m'intéresse.
Passons à mon souci, et pour cela, une explication de ce que je souhaite mettre en place, d'où j'en suis et où est la partie où je bloque...

1. Mon objectif
Au contact d'une carte RFID, l'arduino doit injecter une série de combinaison clavier. L'objectif est de verrouiller/déverrouiller une session Windows. Lorsque le carte est correcte, une diode verte s'allume 2 secondes et exécute la suite de commande prévue. Lorsque la carte n'est pas celle attendue, une diode rouge s'allume 2 secondes.
L'ensemble ne sera alimenté que par l'USB de l'ordinateur.

2. Matériel utilisé
- Arduino Pro Micro 5V (Kookye Pro Micro Atmega32u4)
- MFRC522
- 1x Résistance 1k
- 1x Résistance 2k
- 2x Résistance 100
- 1 Led rouge
- 1 Led verte

3. Schéma du circuit
Voir la pièce jointe "schema1.png"


4. Où j'en suis...
J'ai déjà testé avec l'arduino branché en USB, et les composants sur un breadboard avec une alimentation. Pour mes tests, j'ai directement mis une alimentation externe de 3.3V sur ma carte MFRC522 pour que ca fonctionne. Et les tests se sont bien passés.
Mais comme l'objectif est d'avoir que le cable USB pour l'alimentation et que je n'ai pas de sortie 3.3V sur ma carte Arduino, j'ai mis en place (comme montré sur le schéma) un Voltage Divider pour avoir 3.3V aux bornes du MFRC522.
Avec le voltmètre, je vois bien les 3.3V à l'entrée de ma carte MFRC522 (mesure prise sans la carte MFRC522 branchée sur le breadboard). Dès que je branche la carte MFRC522, à l'aide du voltmètre, je mesure 2.75V aux bornes de la carte MFRC522. Et bien sûr, quand j'approche ma carte RFID rien ne se passe...
Dès que je rebranche mon alimentation externe qui délivre du 3.3V aux bornes du MFRC522, ca fonctionne. Donc je suppose un problème du côté de voltage, mais je ne comprends plus rien... J'imagine que la solution est sous mes yeux, mais je ne le vois pas.
Une bonne âme pour répondre à un petit newbie ? :(

Merci.

kamill

Bonjour,

Si tu fais un diviseur de tension par résistances, la tension va dépendre de la consommation de ton module.
Il faut que tu utilises un régulateur de tension 3.3V.

al1fch

Bonjour

Un pont diviseur n'est pas une solution viable pour abaisser une tenseion d'alimentation.

Le  'pont diviseur' repose sur l'hypothèse que le courant est le même dans les deux résistances du pont ,ce qui est en contradiction avec la fournirure de courant au niveau du point de jonction des deux résistances.

La mise en place d'un régulateur 3,3v s'impose pour alimenter le MFRC522

Electrof

Ok merci. Super efficace comme forum :)

Auriez-vous un régulateur 3.3V à me conseiller svp ? Je le place directement entre mon arduino et le mfrc522 ?

Auriez-vous d'autres suggestions sur mon installation ?

Merci beaucoup

kamill

#4
Jul 10, 2018, 11:51 am Last Edit: Jul 10, 2018, 11:53 am by kamill
Il faut que tu utilises un régulateur "low drop".
Il existe des modules tout montés comme celui ci

Go Up