Go Down

Topic: Continuous Rotation Servos not working (Read 319 times) previous topic - next topic


I bought seven Continuous Rotation Servos. When I tried them, I saw that only one worked, and the rotation wasn't good. The problem I can see is that the gear directly connected to the motor is working, but it isn't connecting to the other gears therefore the top gear does not rotate. Is there a solution? What can I do?
In the sketch I used the myservo.write(0); function.


The solution is to get whoever you bought them from to send you some working servos or to give you your money back so you can buy from someone more reputable instead.



All right... I posted this question because, perhaps, I could do something inside to get the gears inside the servo connected to the motor.


Sounds like your supplier bought cheap servos and opened them up to convert them to continuous rotation but did not reassemble them correctly.

You might be able to open them up and fix them but @slipstick's advice seems more appropriate if they were faulty when supplied.

Two or three hours spent thinking and reading documentation solves most programming problems.

Go Up