Go Down

Topic: Aduino UNO; Mac OS X 10.5.8; Programmer is not responding. (Read 3699 times) previous topic - next topic


Hi all,

I am an Arduino newbie and the following error is being generated when trying to upload my blinking LED sketch:

avrdude: stk500_recv(): programmer is not responding

Model: Arduino UNO
IDE: 0022
OS: Mac OS X 10.5.8
Hardware: MacBook

The IDE and USB driver installed just fine.

I think I have the right serial settings in the IDE and I am sure I have the right model Arduino selected in the IDE too.

Any suggestions?




Try a different USB cable?  Make sure the board is plugged directly into the computer, not through a hub (or keyboard, etc). 

Which serial port are you using?

Do you have any software that could be accessing serial ports?  For example, anything to synchronize PDA's or other devices, or a cellular internet USB dongle, etc.  Try disabling that.


I have the same problem with my MacBook Pro, OSX 10.5.8.

Did this get fixed? It seems that it is a common problem - many postings

I had been using the rev 0019 IDE with a Duemilanove for many months when the problem started.
The upload error message
"avrdude: stk500_recv(): programmer is not responding"
appears twice after the binary sketch size is reported after an upload is started.
I had updated to 0022 a couple of weeks earlier. I had run the board off of a 9V battery the day
the problem started. Since then I have tried several cables, moved to different USB ports, ordered a
brand new UNO, reverted back to rev 0019, reinstalled the USB driver several times. The test sketch
is plain old "Blink". No luck.


I'm having the same connection problem with the UNO board on my MacBook OSX 10.5.8 and Arduino v0022.

How can I check those processes that deal with USB based cellular internet access pen? How do I disable them?
This is last thing I need to try, otherwise I'm returning the board and give up on the arduino stuff. Shame!


The same Uno board and the same USB cable have been used on my MacBook 10.5.8 but running
the arduino app (version 0022) on windows XP through VMWare and it works.

You (developing) guys need to sort this out: it's not the board, nor the USB cable. It's how you interface
and access the USB port on the Mac OS X.


I am glad to learn that VMWare on the same MacBook works.

It seems that Apple had an operating system update that caused the USB timing to the Atmel to change? Why else would several boards work one day and not the next. I can see that I am connected to the Arduino, just am not now able to upload changes. I do not know how Mac OSX users are supposed to resolve this. Are there any upload timing variables even accessible that can address this?

After two weeks of development time lost and no reply from the developers I would gladly scrap Arduino and go with another controller, however I have too much time and hardware invested, considering that a simple SW fix from Arduino is surely possible.

I have attached a list of my experiments to date.


I just went through all of the Arduino pull down menus and changed the Serial port from /dev/tty.usbserial to /dev/cu.usbserial and was able to upload a Duemilanova. Uno requires /dev/tty.usbserial.


i have this same problem. it seems to work with the 0022 IDE but on older mac books. (MacBook3,1 my lectures laptop)

im running a MacBookPro5,1 with 10.5.8 OS/X

bamboola - this is not true (at least for me) as i have tried all ports with no cigar!

Im a sad panda!

Does anyone know if this is being fixed as i have had no success with my arduino and mac and need to get this running for a uni project!




Check my other posts for more info on this problem.

I finally got it to work after disabling a Vodafone/Huawei driver for a GSM/3G pen that
was making impossible the USB serial port access.

This what I did:

- Uninstalled the program
- In Network preferences I deleted the services associated with the pen
- In System|Library|Extensions I deleted the *.kext files associated with the pen

After a reboot Arduino works!


I also run into that same error... only getting the sketch from the day before and not being able to upload a new sketch.
OSX 10.6.7 - Arduino Duemilenove - Atmega 328

However, it was very simple:
For some reason, when I open Arduino the serial port had changed.
I changed it back again (Tools/ Serial Port/ /dev/tty.usbserial-...)


Go Up