Go Down

Topic: [Solved] WiFiNINA (Read 2279 times) previous topic - next topic


Jul 28, 2018, 04:39 pm Last Edit: Aug 28, 2018, 11:40 am by mbanzi
Searching the libraries for Vidor I found the WiFiNINA lib that is supposed to support the Vidor4000. When I try to compile the WifiPing sketch i receive the following Warning and Error

Code: [Select]
WARNING: library SPI claims to run on (samd) architecture(s) and may be incompatible with your current board which runs on (samd_beta) architecture(s).
In file included from C:\Users\Glenn\AppData\Local\Arduino15\packages\arduino\hardware\samd_beta\1.6.22\cores\arduino/delay.h:23:0,

                 from C:\Users\Glenn\AppData\Local\Arduino15\packages\arduino\hardware\samd_beta\1.6.22\cores\arduino/Arduino.h:81,

                 from C:\Users\Glenn\Documents\Arduino\libraries\WiFiNINA\src\utility\spi_drv.cpp:21:

C:\Users\Glenn\Documents\Arduino\libraries\WiFiNINA\src\utility\spi_drv.cpp: In static member function 'static void SpiDrv::begin()':

C:\Users\Glenn\AppData\Local\Arduino15\packages\arduino\hardware\samd_beta\1.6.22\variants\mkrvidor/variant.h:125:25: error: 'SPIEx' was not declared in this scope

 #define SPIWIFI         SPIEx


I did copy the VidorPeripherals Library code to my libraries folder under my sketches/libraries folder and I also did a include Libraries and selected VidorBase to add the base vidor headers to the project.


Hi Glenn,
we're completing wifi support. at the moment that should work in the graphics image but is not completely supported in the peripherals image. that should be updated early next week, adding also the serial interface which is now missing on both sides.


Bump? Both the VidorGraphics and VidorPeripherals repos haven't been updated in two weeks now...


Regarding the github repos, it would be great to write some better commit messages than just "update".

 It helps to understand changes and also in case someone wants to debug something it can really help!

Thanks and keep up the great work!  ;)


I'm the same problem, have you a solution ?


Is there something new about WiFiNINA?, I also gets the error message:

......\packages\arduino\hardware\samd_beta\1.6.22\variants\mkrvidor/variant.h:125:25: error: 'SPIEx' was not declared in this scope

 #define SPIWIFI         SPIEx


almost there.. the graphics FPGA image we pushed yesterday has more or less everything needed. we just need to nail down some details on the arduino side.


Hi Everyone,

Please see the following thread on how to get the new library releases to use WiFiNINA: http://forum.arduino.cc/index.php?topic=563513.0


I still can't get wifinina to compile... Did the update:

New SAMD beta core 1.6.23 release, bootloader and library updates

Rather lengthy error list...

Arduino: 1.8.5 (Windows 7), Board: "Arduino MKR Vidor 4000"

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:333: undefined reference to `SpiDrv::waitForSlaveReady()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:333: undefined reference to `SpiDrv::spiSlaveSelect()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:336: undefined reference to `SpiDrv::sendCmd(unsigned char, unsigned char)'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:338: undefined reference to `SpiDrv::spiSlaveDeselect()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:340: undefined reference to `SpiDrv::waitForSlaveReady()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:341: undefined reference to `SpiDrv::spiSlaveSelect()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:346: undefined reference to `SpiDrv::waitResponseCmd(unsigned char, unsigned char, unsigned char*, unsigned char*)'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:348: undefined reference to `SpiDrv::spiSlaveDeselect()'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:351: undefined reference to `SpiDrv::initialized'

C:\Users\Home\Documents\Arduino\libraries\WiFiNINA\src\utility/wifi_drv.cpp:787: undefined reference to `SpiDrv::initialized'

collect2.exe: error: ld returned 1 exit status

Using library SPI at version 1.0 in folder: C:\Users\Home\AppData\Local\Arduino15\packages\arduino\hardware\samd_beta\1.6.23\libraries\SPI
Using library WiFiNINA at version 1.1.0 in folder: C:\Users\Home\Documents\Arduino\libraries\WiFiNINA
exit status 1
Error compiling for board Arduino MKR Vidor 4000.


Aug 14, 2018, 09:14 pm Last Edit: Aug 14, 2018, 09:15 pm by Juraj
I still can't get wifinina to compile... Did the update:
did you install it with Library Manager and update to 1.1.0?
You can't write an Arduino sketch if you didn't learn programming. Not the language, but the concepts of programming - algorithms and data types.


Hi @VA3SU,

Could you please let us know what sketch you are compiling?


Sorry I should have said but I tried many of the sketches in the WifiNina, AP_Simplewebserver or Scannetworks.



And yes, did the library update to 1.1.0, and using the Arduino ide 1.8.5 of course.


Hi @VA3SU,

Could you please enable "Show verbose output during: compilation" in the IDE's preferences and provide the full build output.

I'm wondering if you library installation got corrupt somehow, as the Travis CI build for the library is working fine: https://travis-ci.org/arduino-libraries/WiFiNINA


Thanks for looking. File attached.

Build of AP simple web server


Go Up