Go Down

Topic: Ardunio IDE "Tools -> Ports " is greyed out (Win10) (Read 213 times) previous topic - next topic

coryjfowler

Drivers for the interface are installed, I can use another application to open up the port and see some of my debug messages from the device.  It is an Adafruit FTDI friend connected to an Arduino Pro.

When any FTDI or CH340 device is connected to this Windows 10 system, the "Tools -> Ports" option is greyed out and not selectable.  Curiously, the 8u2 and 16u2 USB to Serial interfaces work fine ONLY when no FTDI or CH340 based devices are attached to the system.

As a band-aid, I am able to upload to the port by changing the value in the "preferences.txt" file.

I need a serious solution for this nuisance.
"Taking the time to make a proper, punctuated, post is a mark of courtesy and respect."  http://forum.arduino.cc/index.php?topic=149022.0

ballscrewbob

#1
Dec 13, 2018, 06:54 pm Last Edit: Dec 13, 2018, 06:57 pm by ballscrewbob
Win 10 has had some issues for some people with CH340/341 devices.

Most common remedy's are :-

Turn off driver enforcement.
Ensure you can see the COM & LPT ports in device manager.
Install drivers as ADMINISTRATOR (not just a user with admin privileges).
Turn off Antivirus and similar just to do the driver installs and check the uploads work as expected.
Ensure you are using USB 2.0 ports (USB 3.0 can on occasion cause issues).
If it not your own computer get your IT department to raise your user privileges or install the drivers for you.

For the FTDI device make sure you check the above issues first. as there was an FTDI issue over a year ago and I am unsure if windows fixed it or not.

In both cases check you have the latest drivers from the official sources.

CH340 (Chinese but safe)
FTDI

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

DrAzzy

The fact that you can make it work by setting the port in preferences, even though the tools -> port menu is greyed out seems to imply that the problem is with the IDE.

Does running the IDE as admin change anything? If so, that implies a privilege issue.

I do not encounter this issue on either of my Win10 systems; I use CH340G serial adapters almost exclusively, and they work like a charm... I think I've tested with versions up to 1.8.7?

What version of the IDE are you using?
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

pert

This issue of ports that show up in Device Manager/other applications/etc. not showing in the Arduino IDE's Tools > Port menu has been reported several times recently on the forum. I don't remember what resolution (if any) there was in the previous threads. I also have never encountered this problem myself.

Go Up