Go Down

Topic: Ardunio Hallsensor m. TLE 4095L - Drehzahlsprünge (Read 700 times) previous topic - next topic

Doc_Arduino

Hallo,

die Schaltung bzw. Beschaltung des TLE gefällt mir nicht. Vorallendingen der jeweils 10 Ohm Längswiderstand am Ausgang ist etwas seltsam. Was viel interessanter wäre fehlt leider. Die Versorgung des TLE und die weitere Beschaltung am Ausgang des TLE.

Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

bens0r

Den TLE versorge ich über 5V vom Arduino. Gnd zu Gnd und Signal-Ausgang auf Pin2 (interrupt 0).

Da ich sorge hatte, dass es an der Versorgung liegt, habe ich den TLE auch schon am Labornetzteil gehabt. Ohne wirklich einen Unterschied festzustellen.

Über 5V und Signalausgang des TLE's habe ich einen Widerstand gezogen. 1kOhm. Jetzt einen 470Ohm Widerstand(läuft besser).

Doc_Arduino

Hallo,

Okay. Dann ist die Beschaltung etwas unangemessen dafür.
Der Eingangswiderstand R1 soll die TVS Diode vor zu hohen Strom schützen, wenn Überspannungen "reinknallen" soll die diese ableiten/begrenzen. Hast du nicht. Im Grunde kann der Widerstand und die TVS raus.  Der Ausgangswiderstand R2/R3 erschließt sich mir nachwievor nicht so richtig. Stellt ein RC Glied dar, nur wofür? Was hing da früher dran? Eigentlich müssten diese auch raus und der Pullup direkt an den Ausgang/Kondensator C2 bzw. C3. Da würde aktuell nur ein Oszi helfen um zu sehen wie die Impulse/Flanken aussehen.

Mir lässt aber keine Ruhe das du Probleme hast beim starten und stoppen. Die Arduino Versorgung ist getrennt vom Motor? Wieviele Magneten sind an dem Motor die der TLE sieht? Nicht das durch eine Art kurze Pendelbewegung hast die dann zu Fehlerkennungen führen. Gegen generelle Problem spricht ja das du keine Problem hast wenn er schneller dreht wie losdrehen.

Du schreibst auch die Platine sitzt auf dem Motor? Ich meine wenn der losdrehen will gibts Stromspitzen. Ob es dabei kurzzeitige Magnetfeldstreuungen gibt kann ich nicht beurteilen. Aber bau die Platine mal räumlich entfernt vom Motor auf. Wo sitzen die Magenten eigentlich? Oder sollen die TLE die Motormagneten zählen? Mach am Besten paar Fotos wo man das alles erkennen kann.
Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

Go Up