Go Down

Topic: arduino due ATmega16U2 firmware flashen (Read 375 times) previous topic - next topic

twox

Hi!

Ich habe hier diverse Arduino Due Boards aus China. Das bekannte Problem bei denen ist, dass die nicht direkt durchstarten, also man muss da einen manuellen Reset vorher machen.
Um das Problem zu beheben kann man den den 16u2 updaten.
Hier gibt es auch eine Anleitung dazu:
https://www.arduino.cc/en/Hacking/Upgrading16U2Due

Ich bekomme die CMD Zeile einfach nicht hin. Irgendwas stimmt mit dem Pfad nicht. Ich kapiers einfach nicht. :smiley-confuse:

Meine Zeile sieht so aus:

C:\Program Files (x86)\Arduino\hardware\tools\avr\bin>avrdude.exe  -c  C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf   -c  Arduino -p com138 -b 19200 -p m16u2 -vvv -U flash:w: C:\Program Files (x86)\Arduino\hardware\arduino\avr\firmwares\atmegaxxu2\arduino-usbserial/due.hex:i

Was ist da falsch?

combie

Welche Meldung kommt denn?
Welchen Programmer nutzt du?
Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.

twox

Hi!

Danke fürs Antworten. Als Programmer verwende ich einen Arduino uno.
Hier eine Screenshot von der Fehlermeldung:


combie

Vermutlich reicht es, den Pfad in Anführungszeichen zu setzen.
Denn das/die Leerzeichen stört sonst.

"C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf"

Das gilt natürlich auch für alle anderen Pfade
Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.

twox

Leider kommt dann auch die Fehlermeldung....

combie

Alle sagen: Das geht nicht!
Einer wusste das nicht und probierte es aus.
Und: Es ging nicht.

postmaster-ino

Hi

Mal nach der .conf gesucht?
Bei mir (allerdings Linux) unter folgenden Pfaden:

/home/postmaster-ino/Downloads/Arduino-Zeugs/arduino-1.8.5/hardware/arduino/avr/bootloaders/gemma
/home/postmaster-ino/Downloads/Arduino-Zeugs/arduino-1.8.5/hardware/tools/avr/etc

Das sind allerdings nur die Downloads für sie Linux-Installation bzw. ggf. Deren entpackte Inhalte.
Ich schlussfolgere aber, daß sich diese Datei bei Dir im Arduino-hardware-Verzeichnis befinden.

MfG
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

ard_newbie

Das bekannte Problem bei denen ist, dass die nicht direkt durchstarten, also man muss da einen manuellen Reset vorher machen.
Die einfachste Lösung, Antwort #81 :

http://forum.arduino.cc/index.php?topic=256771.75

twox

Super! Vielen Dank! Die Lösung mit dem Kondensator ist wirklich die einfachste!!!
Dank an alle!

Go Up