Go Down

Topic: vidor 4000 fpga sketch will not load (Read 1 time) previous topic - next topic

G0dz1lla2018

Hi,

I am running the IDE on a mac OSX.

The blink test works.

This sketch compiles.


#include "VidorPeripherals.h"

void setup() {
 Serial.begin(115200);
 while (!Serial) {}

 // Let's start by initializing the FPGA
 if (!FPGA.begin()) {
   Serial.println("Initialization failed!");
   while (1) {}
 }

 // Let's discover which version we are running
 /*
 int version = FPGA.version();
 Serial.print("Vidor bitstream version: ");
 Serial.println(version, HEX);

 // Let's also ask which IPs are included in this bitstream
 FPGA.printConfig();
 */


}

void loop() {
 // put your main code here, to run repeatedly:

}


However, when I try to upload I get an error...
SAM-BA operation failed
An error occurred while uploading the sketch

at about 46%..

What is going on ?
Attached is the error log....


Best regards,
Phil Neal



sandeepmistry


G0dz1lla2018

Hi,

Go to the 'FPGA boot loader recovery' post.
I did what it said and my Vidor now runs !!!

Vidor bitstream version: 1020107
number of devices 9
1 01000000 MB_DEV_SF
1 02000000 MB_DEV_GPIO
4 04000000 MB_DEV_I2C
6 05000000 MB_DEV_SPI
8 06000000 MB_DEV_UART
1 08000000 MB_DEV_SDRAM
4 09000000 MB_DEV_NP
11 0A000000 MB_DEV_ENC
0 0B000000 MB_DEV_REG
Pin A0 is HIGH


However, my Vidor doesn't revert back to a loadable state. The red led goes away and never
comes back on. I have to double-tap the blue button.

Phil

G0dz1lla2018

Hi,

Yep. I am up to date on the bootloader, libraries, etc.

Phil

Allmaker

Hi,

i'm trying to load the example video gfx on vidor 4000.

I've update software, boards en library but the programming process stop at 37%.



[===========                   ] 37% (3968/10635 pages)write(addr=0x20005000,size=0x1000)
writeBuffer(scr_addr=0x20005000, dst_addr=0x40000, size=0x1000)

at this point give me an error



DarioPennisi

@Allmaker please confirm you already updated bootloader as per Sandeep's post above. if you don't update bootloader FPGA will not revert to boot image on entering samd bootloader and won't be able to update.
basically when loading code you should see hdmi output show arduino logo.

@G0dz1lla2018  please confirm that when starting upload samd goes in bootloader mode (LED pulsing and arduino logo on HDMI output). if it doesn't then either the USB serial port is not configured correctly or you are not on the new bootloader.

sadr0b0t

I'v just got brand new Vidor by mail, installed today's recent Vidor support package (1.6.23), libraries Vidor Graphics (1.0.3).


VidorDrawLogo does not flash at 37%.

Updated board firmware as described above, now UpdateBootloader in Serial monitor shows:

Quote
Welcome to the Arduino SAMD bootloader updater
----------------------------------------------
 
Checking if bootloader requires an update ... bootloader is already the latest version
 
Update is not required :)
but VidorDrawLogo stil does not flash at same 37%.

VidorTestSketch does not flash at 46%

Both show "SAM-BA operation failed" message

sandeepmistry


sadr0b0t

Hello, I have searched through the forum and found another thread with another option to fix:

http://forum.arduino.cc/index.php?topic=561393.0

I have applied FPGARecovery from this archive
http://downloads.arduino.cc/tools/VidorFPGARecovery.zip

and now VidorDrawLogo flashed 100% and draws Arduino logo on my TV

HMejiaU

Hi, I received my new vidor fpga card two days ago, and I haven't been able to load the "Blink" sketch.
I'm running the IDE (ver. 1.8.7) in windows-10, with the Arduino SAMD beta boards (ver. 1.6.24) installed.

The sketch takes a long time to compile, and after a few minutes I see the the message "An error occurred while uploading the sketch".

I already tried the solutions in the "Arduino Forum >  Products >  MKR Boards >  MKRVIDOR4000 >  [Solved] FPGA boot loader recovery"; I tried the "VidorFPGARecovery", I'm attaching the console dump. Everything went fine, but the red light remained off after the process.

Afterwards, I tried to load the blink sketch with the same wrong result.

Awaiting for your advise!

Thanks
 

DarioPennisi

Hi Humberto,
you should update FPGA bootloader update as per this post: http://forum.arduino.cc/index.php?topic=563513.0

this is different from the boot loader recovery which, is needed if you corrupted boot image and was loading an old version.


another hint is that even with new bootloader it may happen that the board won't go in boot mode automatically so you have to doubletap the button when loading the sketch.

let me know if this solves the issue.
thanks,

Dario

Grumpy_Mike

#11
Oct 02, 2018, 05:03 pm Last Edit: Oct 02, 2018, 05:04 pm by Grumpy_Mike
Having done all the updates I find that after uploading code I have to open the serial monitor before anything will start running.

Alternatively it will start by itself if I open the serial monitor before downloading.

Finally by removing the while (!Serial) line from the example it loads irrespective of the serial monitor's status.

This was using the VidorDrawLogo sketch.

Is this the intended operation mode?

DarioPennisi

Hi,
Yes... There should be comments on sketches saying you should comment that if you don't want to use serial.
It's a bit misleading to who is not used with Arduino boards with USB but this is the standard behaviour...

Go Up