Go Down

Topic: Arduino Nano CH340 driver macOS (Read 2367 times) previous topic - next topic

lukasniestrat

I can't install the CH340 driver for MacOS to compile my sketch to the Arduino Nano Board CH340/ATmega328P. (this board)

I tried to install with this manual: https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

But it won't work... if I plugged in the Arduino Nano into my Macbook Pro 2017 there is no driver in /dev/ Maybe there is a pitfall I don't know.. Has everyone the same issue?

MacBook Pro 2017 - connected over USB C to USB dongle MacOS High Sierra v10.13.6

thanks a lot!

spycatcher2k

Quote
I can't install the CH340 driver for MacOS
This is either a MacOS question or a CH340 Driver question, but NOT an Arduino question, this is why the answers are lacking!
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

DrAzzy

My understanding is that the official CH340G drivers from the manufacturer's website work with high sierra now, and has been for months...
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Captain_Pugwash

Try this, it worked for me!

Download the zip package, rather than the pkg standalone file.

For High Sierra. Run the package installer for CH340 V1.4 and reboot.

Check with your Arduino IDE, the result is no serial port for your Nano.

Go to Preferences/Security Pane, you will see that your Mac is blocking
content being uploaded. Unlock with your password and Click "Allow".

Check the box next to the USB Serial Modules Manufacturer's name, accept and reboot.
The manufacturer's name is in the readme file that comes in the zip version.

Now run the package installer again and reboot.

Now restart the Arduino IDE and your new USB Serial port should show in the menu.

alanis480

As of not so long ago, a new boot loader came out for the Nano.  Check which board type your Arduino is set to, and try setting it to "Nano (old boot loader)". Hope this helps.

jwallis

I just used the repo the original poster gave, followed the installation directions exactly, using the file CH34x_Install_V1.5.pkg and it worked for me.

-Chinese ebay Nano with title "USB CH340G Nano V3.0 16M 5V ATmega328P Micro-Controller Board For Arduino"
-Ardiuno IDE 1.8.9
-OSX Sierra 10.12.6
-Macbook Air Mid-2011

Go Up