Go Down

Topic: [PROBLEM]Serial Communication Between NodeMCU and Arduino Mega2560 (Read 598 times) previous topic - next topic

melbryanflores316

Hello guys good evening, I do have a problem with serial communication (NodeMCU to arduino mega2560), but with Mega to nodeMCU I don't have.. but with passing short values, it's alright..

PaulS

Quote
I do have a problem with serial communication
What is the problem, and how do you know you have that problem?
The art of getting good answers lies in asking good questions.

melbryanflores316

What is the problem, and how do you know you have that problem?
The a.Mega2560 when receiving it do go to lower voltage and when i remove the rx,tx, the data from nodemcu goes to serial monitor and the voltage goes well

Robin2

You need to make a simple diagram showing how you have everything connected and post a photo of the diagram. See this  Simple Image Guide

Then you can explain where and how you are measuring the voltage.

...R
Two or three hours spent thinking and reading documentation solves most programming problems.

melbryanflores316

the lights goes dimm, btw i already solved it, i changed my nodemcu. it goes well

Robin2

the lights goes dimm, btw i already solved it, i changed my nodemcu. it goes well
Glad to hear you have it working.

...R

PS ... For future reference comments like "the lights go dim" do not help us to help you because we have no idea what lights you are talking about.
Two or three hours spent thinking and reading documentation solves most programming problems.

Go Up