Go Down

Topic: Arduino NANO not read EEPROM while only external power (Read 195 times) previous topic - next topic

unknow001

Dear community,

I have Arduino NANO with extral power supply. From 12V I am getting 5V which is connected to Vin pin of Arduino. Two GND pins of Arduino are connected together towards power supply. I have some values stored in EEPROM which I read on startup (in setup block code). EEPROM values are correct only if I have plugged USB. While I use only external power supply, EEPROM values are wrong (looks like it return only zeros). Does anyone knows why this happens? Why EEPROM can not be read while not USB connected?

Thanks for help!
 

Idahowalker

#1
Sep 24, 2018, 07:44 pm Last Edit: Sep 24, 2018, 07:53 pm by Idahowalker
Have you tried putting the 12V as VIn?


My understanding of what you wrote is that you have a 12V supply that is regulated down to 5V which you are putting in the VIn. My guess, is that the VIn goes through some electronics to protect the device and to regulate VIn down to 5V but, because 5V is the VIn, the circuit is dropping the voltage to less then 5V and that may be affecting the EEPROM's ability to do its thing.

Quote
documentation on this web page says 7-12V recommended and 6-20V limited for Vin. Vin is on 5V regulator input. It is better to use Vin of course. You can connect directly to 5V input but regulated 5V voltage with respect of MCU needs. On-board regulator is bypassed in this case.
https://forum.arduino.cc/index.php?topic=408480.0

unknow001

Yes, you are right. Vin need more than 5Volt. Now it works without problem. Thanks!

Go Up