Go Down

Topic: ESP8266 - Current issue on boot? (Read 328 times) previous topic - next topic



So I'm having a nightmare with this and hopefully someone can shed some light on it... now I THINK it's a current issue but I could be completely wrong...

I'm trying to trigger an optocoupler with an ESP8266, with the optocoupler connected to the TX pin (GPIO1) of the ESP-01 module. If I don't have this TX pin connected to the breadboard then the ESP-01 boots up fine, the Wi-Fi starts and the built-in blue LED is nice and bright. If I then plug the TX pin to the optocoupler it will all work fine.

Now, if I have the TX pin connected at boot, the board doesn't boot properly. The Wi-Fi never starts and the onboard LED is very dim.

Is this a current issue or a pin at start issue?

I've attached a breadboard of what I have set up. There is some other stuff connected but I don't think it's making any difference to the issue I'm having.

I am powering it all from the USB to TTL 3.3v but I have also tried it with the IRM-2-3.3 which is a 230v to 3.3v PSU and the same behaviour which makes me think maybe it isn't a current issue as that should be able to output 600mA.

Thoughts please! :D


If the optoisolator is connected to pin 3 (GPIO2) of the ESP then it may be affecting the ESP's boot mode.  See this page.
You will save everyone's time if you read and follow the forum guidelines.  https://forum.arduino.cc/index.php/topic,148850.0.html


If the optoisolator is connected to pin 3 (GPIO2) of the ESP then it may be affecting the ESP's boot mode.  See this page.
It wasn't connected to GPIO2 but to the TX pin which I believe was GPIO1. I did however just find on the internet that this also needs to be high for boot but it doesn't say it in the datasheet? I swapped it to the RX pin and that seems to have solved the issue.

Go Up