Go Down

Topic: In case you are having problems with MacOS Mojave and CH340 USB Drivers (Read 34638 times) previous topic - next topic



I FINALLY got this to work using
recommendations....  Thankyou Adrian Mihalko!!

including the last steps disabling SIP (and re-enabling after installation):
csrutil disable
reload drivers (I used brew method)
csrutil enable

Thank you for all your tips.
Good luck!


Hey guys... I do have fairly convincing proof that Mojave includes the working drivers for CH340 (and FTDI) as I just go a MBPro and did a clean install of the latest (OS X 10.14.2).  I did not attempt to install any drivers and with a fresh install of the Arduino IDE, I was immediately able to program some Nano boards and use the Serial Monitor.  Works great!

One hiccup was that my Nano boards must have the old bootloader on them but once I switched the processor type to "ATmega328P (Old Bootloader)" it worked like a champ!

So it is likely that if you've already installed the CH340 driver previously, then any problems are due to that.


Another sources of error
* you are using an  USB cable which has no data lanes, try one with data lanes
* the device is connected to an USB 3.0 port, try an USB 2.0 port


Okay this is how to make the nano work with Mojave. I made it work and you can too.

1. reinstall the new ch340 drivers.

2 verify the serial ports in the Arduino programing environment  say /dev/cu.wchusbserial1410.

 3. https://support.apple.com/kb/DL1572?locale=en_US  Install the old java from this link.

..Once this is done. Delete version 1.8.8 and instal version 1.6.13 from the archive and you should be working again.

This will not work with the latest version 1.8.8 at least for me. I'm back up and programing devices using the ch340 again.


I was also having this problem, and was able to solve the issue by deleting both drivers and restarting my MacBook Air.


Jan 24, 2019, 01:29 am Last Edit: Jan 24, 2019, 07:41 pm by mario45 Reason: mistaken number of pins
after "almost endless" unsuccessful trials: deleting, installing, rebooting, .... I found that, in my case, the problem was with the USB female connector in the (Chinese) Nano board. It was slightly, very slightly loose around the terminal connector, and just moving the plug (USB 4 pins) until some resistance was found, the ports /cu.wchusbserial1410 and /cu.usbserial-1410 appeard in the list, and I was able to upload a sketch. Can't say I'm happy, this is casually reproducible situation. .... (No, sorry, it's USB 5 pins, seems working well ).


I am unable to get started with my starter kit. I have a Mac running Mojava 10.14.2
Total newbie here. Already spent two hours trying to do something but this is all a different language to me.
Sad and frustrated. Why isn't there an organized post or something clear to help beginners get started?

Please please help.

Thank you.


Sad and frustrated. Why isn't there an organized post or something clear to help beginners get started?
Arduino does provide quite a bit of documentation to help beginners get started:
The information on the forum will tend to be much more chaotic and disorganized due to the nature of forums. Usually you can find the information you need after spending some quality time with Google but it's not terribly efficient.

Please please help.
We won't be able to help unless you provide detailed information on what the problem is.


So I've been at this for over 10 hours straight now trying to upload a sketch to my ESP8266 and I still can't get the port to show in Arduino IDE.  I've tried installing drivers, deleting drivers, all kinds of magic in terminal - still no go. I am on a powerbook mid 2012 running OSX mojave 10.14, so i also tried the "legacy driver" just in case, nothing seems to work.

I did however notice that the driver at /Library/Extensions/usbserial.kext is indeed installed, but the other at /System/Library/Extensions/usb.kext doesn't seem to be there. Any idea if the path has changed in mojave? Any sure fixes yet? The device is legit - no a chinese knockoff and the cable is indeed a data capable one, so that is not the issue.

I would love some help if anyone has any ideas.


I have the same the same problem as Betyar. I am also a newbie. I have tried everything and nothing seem to work. I have tried the terminal thing downloading all kinds of stuff. I have a MacBook Pro 13-inch, 2018, Four Thunderbolt 3 Ports and version 10.14.3 Mojave
plzzz help


I had this solution working well with my Mac mini late 2012, but now I'm trying with new Mac mini from 2018 and it doesn't work. Any idea?


I have the same problem in High Sierra and nothing works!
Please Help :(


I had this solution working well with my Mac mini late 2012, but now I'm trying with new Mac mini from 2018 and it doesn't work. Any idea?
I think the usb3.1 has some major issues. Been on this for more than 24hours!!!! have you fiund a solution yet?


Finally got my ESP8266 (Nodemcu... "New version" according to Amazon) I struggled with this for a couple of days trying to get my macbook (Mojave 10.14.3) to just see the thing.
Tried with the ch340 drivers. Nothing.
Tried deleting the drivers. Nothing.
Tried holding the flash button.
Tried holding the reset button.
Tried resetting while holding the flash button.
Tried many combinations of the above. Nothing.
Looked at the amazon page, and realized i don't have the ch340 UART. My version has the CP2102. Aha!
Install CP2102 driver from Silicon Laboratories. Nothing.
Go through everything again, twice.
Shelved it and was working on testing a repaired usb joystick. The driver didn't come with any sort of testing program, so I installed USB Blaster. It came up with a security prompt that opened up the security panel in preferences and showed that two programs were blocked, USB blaster and the driver from Silicon Labs.
Unblocked and it seems to be working. I can at least see the thing in /dev/tty now, and it shows up in the arduino IDE. I haven't flashed anything yet, but maybe this will help someone else.

Go Up