Go Down

Topic: Connection to Adafruit.io from MKR1010 (Read 1 time) previous topic - next topic

chrisbuck

Hi all,

I'm having some trouble getting my new MKR1010 working with Adafruit.io.  For background, I've previously created projects with the MKR1000 on Adafruit.io, and I can use the examples from the WiFiNINA library on my MKR1010 to do things that do not use Adafruit.io.  

Unfortunately, the MKR1010 wasn't directly supported in the Adafruit libraries.  I was able to extend them as far as I could figure out, but I'm getting connection rejections that I can't figure out.

I understand this is probably a better question for the Adafruit forum, but I was unsuccessful getting specific guidance there.  I think there must be some difference between the Wifi101 library the MKR1000 uses and the WifiNINA library the 1010 uses that causes the connection to be rejected.

There's a bunch of info in the Adafruit.io forum post.  Since I'm not 100% sure what the problem is, I can't summarize here without fear that I'm leaving out an important detail so I thought I'd post the thread from the other site, which is here:  https://forums.adafruit.com/viewtopic.php?f=56&t=140834&p=699321&sid=f3c5e1aa616f86e1fd281f97bf0d1952#p699321

Thanks in advance for any tips that might help me troubleshoot further would be incredibly helpful.  I'm just running the basic pub example from the Adafruit.io library for this, which works flawlessly for the MKR1000.

sandeepmistry

Hi @chrisbuck,

Does the sketch you are using use WiFiSSLClient?

If so, please follow this thread on Github: https://github.com/arduino-libraries/WiFiNINA/issues/19

chrisbuck

Hi Sandeep,

Yes, I am, and that's probably the issue.  Thank you so much for pointing me here!  I have a MKR1000 I'll use for this project until the issue with the certs for the MKR1010 are resolved.

Go Up