Go Down

Topic: MKRZero no longer recognizing SD cards (Read 492 times) previous topic - next topic


Oct 07, 2018, 01:22 am Last Edit: Oct 07, 2018, 04:19 am by CapM
Edit- This appears to be purely a mechanical failure. I can carefully adjust the SD until it seats properly and is detected. I'm going to just swap it out, thanks for looking though.
Hi all,

I'm new to Arduino, but think I'm getting a decent hang of things. I have a program taking sensor readings and saving to a log file, all pretty simple stuff. At some point while working on it, the program was no longer creating files on the SD card. Thinking I'd messed something up, I tried a known working version of the code and it still wouldn't create files. I tried numerous SD cards, cables, ports, all should be just fine and even as a secondary I reformatted the cards. After some other attempts and research, I ran the CardInfo.ino that is in the IDE Examples, and it outputs:

Code: [Select]
18:46:31.779 -> Initializing SD card...initialization failed. Things to check:
18:46:33.794 -> * is a card inserted?
18:46:33.794 -> * is your wiring correct?
18:46:33.794 -> * did you change the chipSelect pin to match your shield or module?

I did try a few different chip select pin settings in the CardInfo.ino but it should be SDCARD_SS_PIN

I'm not really sure what else to do to debug this, I've tried a lot more than I listed above but I'm willing to retry anything. To me it feels like the Arduino itself has the issue? But I really don't know. I can provide verbose build log, it just made this post too long. Any help is much appreciated, thank.

Go Up