Go Down

Topic: Control de LED con TIP122 entrega menos Voltios (Read 1 time) previous topic - next topic

surbyte

En general hoy casi todo viene de China asi que... ese concepto de que porque es chino es malo... creo que no corresponde salvo el control de calidad.
Por supuesto que se fabrican en Malasia, Filipinas, Singapur, Vietnam, etc etc etc.

El TIP122 toma una corriente de base de 120mA a 4A y tu Arduino no puede entregar mas de 40mA

Entonces ahi tienes una limitación por usar Darlington. Si usaras un MOSFET eso no te pasaría. Seria casi como el RELE.
un IRL520 sería suficiente para tu caso.

Entrega 9.2A con un Vgs de 5V
Tiene una Rds de 0.27ohms o sea que se va a comportar muy bien.

Olvidate de los TIP o Darlington y usa MOSFET con los LEDs siempre

Los IRL son para 5V los IRF son para 10V aunque si compras un IRF530 el que le sigue tendra un comportamento mas o menos adecuado a 5V
Según donde vivas los IRL no son tan fáciles de conseguir aunque creo que eso ya es cosa del pasado.

tauro0221

Hi,
Con todo respesto creo que aqui el mosfet, darlington no es el problema. En el hilo1 tu dices que con el relay te sucede lo mismo. Queire decir que puedes poner cualquier componente para prender los LRDs y te va  a dar  el mismo problema. No hay sustituto para un relay pues el contacto del relay cuando cierra es de zero ohmios comparado con un transistor que va a tener una perdidade de voltaje entre el colector y el emiter. Tu tienes un problema que debes de resolver el de porque la perdida de voltaje. El problema del relay es de como energizarlo pero ningun componente te va a dar una salida de voltaje mejor como la del contacto del relay.  El contacto tiene zero ohmios. Y como dijo el chapulin colorado "pues me doy"

Pablo_Lucini

De hecho , según la hoja de datos, el tip122 tiene un hfe de 1000. Deberías necesitar apenas 4mA para manejar una carga de 4Amp. Evidentemente hay alguna caida de tensión en algún lugar que estás omitiendo medir. Yo haría una medición paso a paso del circuito con carga, o sea, encendé la tira de leds (  con relé, transistor o lo que quieras ), y medí con el tester la caída de tensión en cada parte ( cables, contactos, protoboard o lo que sea que estés usando ). En algún lugar tiene que estar esa diferencia de tensión, posiblemente sea un contacto resistivo. No te rindas

Mke82

Buenas... gracias a todos por la ayuda.


Les comento los avances.

Duplique el grosor de los cables q estoy usando y la cosa mejoro muchisimo. Sigue sin ser perfecto pero ya alcance los 11v. Pase de 8v originales en mi primer post a 11v con lo cual ya me conformo y ademas cómo alguien ya mencionó en algun mensaje, seguro con la plaqueta final esto no deberia pasar.

Asi q creo q asi lo voy a dejar nomas.

Pablo_Lucini

Si vas a hacer una plaqueta para este circuito recordá hacer bien anchas las pistas de la etapa de potencia, inclusive te conviene estañarlas para darle más sección y evitar sobrecalentamientos que terminen en la destrucción de la placa. Suerte

Mke82


Go Up