Go Down

Topic: Motor Driver L298N entrega menos voltaje (Read 158 times) previous topic - next topic

MrTkila

Oct 12, 2018, 03:27 am Last Edit: Oct 12, 2018, 03:37 am by MrTkila
Estoy tratando de usar un L298N para alimentar una pista de carritos a escala junto con el Arduino para controlar cuando avancen los carros, los autos siguen el mismo principio que todos los motores de corriente directa y funcionan a partir de los 12 v sin problema en una pista normal. Cuando alimento el driver con el Arduino este da a la pista los 5v que el Arduino le alimenta, pero cuando coloco un transformador de 12V 2A conectado al driver solo despacha 1.2 V a la pista.

Tengo 4 drivers L298N y todos tienen el mismo problema por lo que descarto que sea problema del driver. No entiendo que puedo estar haciendo mal para que no entregue los 12v del transformador a la pista. Ya le he quitado el jumper y he puesto un cable desde el pin 5 V del Arduino al conector donde conectas los 5v para alimentar la parte logica de la tarjeta pero no prende.

Este es el código con el que estoy probando mi driver:



int IN1 = 9;
int IN2 = 8;

void setup() {
pinMode(IN1, OUTPUT);
pinMode(IN2, OUTPUT);
pinMode(13,OUTPUT);
}

void loop() {
 

digitalWrite(IN1, LOW);
digitalWrite(IN2, HIGH);

digitalWrite(13,HIGH);

}

MrTkila

Ya encontré la solución, le tuve que quitar el jumper del regulador por que aunque el rango diga de 5 a 12V el regulador se come gran parte del voltaje de salida, por lo que es mejor quitarle el jumper como si fuera a trabajar a mas voltaje.

Por otra parte, yo pensé que nada mas tenía que conectar el cable de 5 del Arduino pero aprendí que también tengo que poner el cable de GND del Arduino compartiendo conexión con el del transformador.

Anexo imagen para mayor referencia. Gracias por su atención.

Go Up