Go Down

Topic: Conseils moteurs, boutons poussoirs & alim (Read 804 times) previous topic - next topic

jpbbricole

#15
Oct 14, 2018, 05:25 pm Last Edit: Oct 14, 2018, 05:27 pm by jpbbricole
Super, ben du coup merci je vais me touner vers ceux la

Du coup, je vais avoir deux moteurs : moteurs pas à pas
Je vais donc devoir les alimenter avec une alim externe de 12v et de minimum 1A si je ne me trompe pas  ?
Je mettrai plutôt au moins 2A.

Une fois que tout ce beau monde a la bonne tension avec une intensité suffisante ( dites moi si je m'exprime mal, je ne suis pas super a l'aise encore ) il faut mettre en commun les masses ?
Oh que oui!

Je devrai aussi l'alimenter autrement qu'avec l'arduino ? j'ai peur que l'arduino ne soit pas capable de lui fournir le nécessaire ( il nécessite 0.5-0.6 A en 4.6 -6v). Sachant que l'arduino alimentera déjà le capteur de couleur ! Il me faudra donc une autre alim de 6V ( qui pourrait éventuellement alimenter l'arduino par la même occasion  ?
Attenttiol l'Arduino c'est entre 7 et 12v (Vin) 9v est préférable. Je te conseille d'oublier le 5V de l'Arduino et de faire comme suit:
depuis l'alim principale 12v. qui va alimenter les moteurs pas à pas (MAPA) tu achète une poignée d'abaisseurs de tension comme ceci,  tu en prend 1 pour faire du 5V. pour les servo, capteur de couleurs et d'autres futurs périfériques et un autre pour faire du 9v. pour le jack (Vin) de l'Arduino.

Cordialement
jpbbricole


68tjs

+1
On trouve en ligne ces produits sous le nom de "convertisseur abaisseur de tension" ou "step-down converter" a des prix bien plus bas (ebay : 5 fois moins cher mais délais de livraison 3 à 4 semaines).
Tout dépend si tu privilégies le prix ou la rapidité de livraison.

Livraisons rapides et un peu moins cher mais en France :  https://fr.shopping.rakuten.com/s/convertisseur+de+tension?s=1

david74

Salut, encore merci pour vos éclaircissements !

Le fait de n'avoir qu'une seule alim pour toutes la machine est en plus bien plus pratique !

Pour ce qui est des abaisseurs de tensions, c'est une super idée merci !

Ils sont réglables donc ? ( en haut a droite, l'éspèce de potentiomètre gris sur la lien envoyé par jpbbricole ? )

Si je prends une alim 12v 3 Ampères, ( disons que les moteurs pas à pas tournent a fond ( ils sont annoncés a 0.4 on va prendre large 0.8 chacun ) ce qui donne 1.6A pour les deux, ensuite l'Arduino ( Uno ou Nano ) avec un abaisseur de tension pour la réguler a 9v il pomperait 0.5 ? l'abaisseur prendrait-il un peu aussi ?
Même cas pour le servo, il est annoncé a 0.6A, mais si j'utilise un abaisseur pour mettre la tension aux alentours de 5V va t-il pomper plus de courant ?

Navré si mon paté est flou, j'ai essayé de faire au mieux j'ai peur de m'être très mal expliqué

jpbbricole

#18
Oct 14, 2018, 06:20 pm Last Edit: Oct 14, 2018, 06:22 pm by jpbbricole
Ils sont réglables donc ? ( en haut a droite, l'éspèce de potentiomètre gris sur la lien envoyé par jpbbricole ? )
Oui

Si je prends une alim 12v 3 Ampères...
C'est bien de prévoir large.

un abaisseur pour mettre la tension aux alentours de 5V va t-il pomper plus de courant ?
Non, ces abaisseur ont un rendement assez élévé.

Pour information, le driver moteur pololu proposé par Jpbbricole se pilote avec 2 broches. Une broche pour indiquer le sens de rotation du moteur, et l'autre pour faire avancer les pas.
C'est 3 broches, ne pas oublier le signal ENA, qui permet de désactiver le driver ainsi le les MPAP ne reste pas toujours sous tension (surchauffe) Se signal serait commun s'il y a plusieurs drivers.

Bonne soirée et bonne bricole
jpbbricole

david74

Salut, j'ai essayé de faire un montage avec Fritzing, c'est pas très clair, j'espère que ça reste lisible !




La batterie n'est pas la bonne, j'ai mis ce que j'ai trouvé.
Je n'ai pas mis non plus de régulateur de tension entre la batterie et le Servo / Capteur de couleur, mais il y en aura bien un ( 5V )
Tous les fils des moteurs pas à pas ne sont pas non plus branché, j'ai surtout voulu faire un schéma pour l'alimentation.

A première vue un câblage comme ça vous semble correct ?

Merci d'avance ! ;)

jpbbricole

Salut david74

Il faut mettre les GND de l'Arduino et de l'alimentation externe ensembles. Il sont pontés au niveau des drivers de MPAP, mais, en général, on ne "compte" pas dessus.

Le câblage des MPAP est tout droit.

Cordialement
jpbbricole

david74

Salut jpbbricole !

Merci pour ces précisions !
Les schémas de branchement que tu as envoyé sont bien plus précis que les miens, je pourrai m'en servir !

J'ai hâte que tout le matos arrive afin d'entrer dans le vif du sujet  :smiley-evil:


Go Up