Go Down

Topic: Re: Ruido en arduino con relés [SECUESTRADO] (Read 607 times) previous topic - next topic

oyale

Oct 12, 2018, 11:10 pm Last Edit: Oct 13, 2018, 08:34 am by oyale
(Viene de aquí)

Acabo de caer por aquí, yo tuve un problema idéntico y la solución fue exactamente esta: quitar el puente y darle una fuente de alimentación propia al módulo de relés. En mi caso, en su día utilicé un nano alimentado por USB, del que sólo usaba sus pines para alimentar el módulo.

Ahora he encontrado esto, que parece abordar el problema de las interferencias también directamente con otra fuente (microUSB, se agradece) y tierras aisladas.

No necesito el retraso para nada, pero me parece ideal para casos como estos.



¿Puedo sugerir otra prueba?



El módulo de relés lleva un jumper para que puedas alimentar el circuito a través del arduino o con una fuente externa. Quitalo y usa una fuente separada para el arduino y otra para los relés. Para hacerlo, el pin RY-VCC y GND (donde estaba el jumper), deben ir a la fuente externa. Yo pondría un condensador de 2200uF a la salida de la fuente, ya que estas son por no decir malas, algo peor.

El Arduino lo alimentas con otra fuente, a través del jack por ejemplo. Y llevas el pin de control y +5V al modulo de relés, a los conectores de los relés. No hace falta llevar GND.

Y luego a falta de snubber, pondría un varistor entre los contactos del relé. Lo puedes sacar fácilmente de alguna fuente vieja o rota. Aunque también puedes probar sin él.

Si lo pruebas me cuentas.

tauro0221

Hi;

Aqui creo que hay tres soluciones para resolver el problema que se produce cuando se abre/ ciera un conctato para energizer un motor electrico,  Una es la de usar un relay solido de AC que sea de "cruze de zero"  como lo sugerio surbyte  y la segunda la que sugerio victorjam de usar un mov en paralelo a los contactos. Yo normalmente uso MOV que sea de 30 a 40 voltios sobre el voltaje de operaciones o sea si el voltaje de operacion es de 230 entonces usaria un MOV de 275 voltios o el que sea mas cercano a ese voltaje. Tambien como lo sugerio victorjam de usar lo que se conoce como un snobber. Este es de una resistencia de 50 a 100 ohmios en serie con un  condensador de  .1uf 400voltios    conectado en paralelo a los contactos del  relay. Esto lo que hace es absober el ruido cuando se abre/ciera el contacto. Este ruido causa que el micro se vuelva erratico y es loque se esta experimentando el rpojecto al prender el motor.

surbyte

A ver porque se empeñan en revivir hilos viejos?
Que @oyale que es nuevo y obviamente no sabe leer lo que un Warning significa esta claro, pero tu @tauro para que le respondes?
Nadie ve que es un hilo del 2017

Hilo cerrado y luego movido a un tema nuevo.

oyale

#3
Oct 13, 2018, 08:21 am Last Edit: Oct 13, 2018, 08:29 am by oyale
¡Perdón! No ví ninguna referencia a reflotar hilos antiguos en las normas del foro. Estaré más atento a los warning.

surbyte

#4
Oct 13, 2018, 06:04 pm Last Edit: Oct 13, 2018, 06:27 pm by surbyte
Moderador:
La referencia aparece en letras rojas @oyale

No respondas mensajes con 120 sin movimientos que además te dicen Warning en letras rojas.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.


Respecto de este tema si tienes mas consultas por privado.

Tu solución es agregar un temporizador que desplaza el problema X segundos pero el transitorio seguirá ocurriendo.
No niego que te haya solucionado tu problema. Pero no todos los problemas son similares.

Un transitorio no lo resuelves postergando el accionamiento X segundos de un contactor.
Supongamos que le pones un retardo de 10 Segundos, a los 10 segundos tienes el transitorio de la bobina del contactor y me dices que con ese rele temporizado evitas que un arduino se reinicie sin usar MOV o TVS? Lo tengo que ver pero en principio no lo creo.


Go Up