Go Down

Topic: Help me.(MLX90614) (Read 91 times) previous topic - next topic

Ibrahim8844

Oct 14, 2018, 02:17 pm Last Edit: Oct 14, 2018, 02:20 pm by Ibrahim8844
i am doing a mlx90614 arduino project.
so my arduino mlx90614 project was working perfectly until some day ago in the serial monitor there is no temperature reading coming up. my code and everything is fine but still there is no temperature reading. so can anyone help me what to do with this problem.

this is the code i am working with

/***************************************************
 This is a library example for the MLX90614 Temp Sensor

 Designed specifically to work with the MLX90614 sensors in the
 adafruit shop
 ----> https://www.adafruit.com/products/1747 3V version
 ----> https://www.adafruit.com/products/1748 5V version

 These sensors use I2C to communicate, 2 pins are required to  
 interface
 Adafruit invests time and resources providing this open source code,
 please support Adafruit and open-source hardware by purchasing
 products from Adafruit!

 Written by Limor Fried/Ladyada for Adafruit Industries.  
 BSD license, all text above must be included in any redistribution
****************************************************/

#include <Wire.h>
#include <Adafruit_MLX90614.h>

Adafruit_MLX90614 mlx = Adafruit_MLX90614();

void setup() {
 Serial.begin(9600);

 Serial.println("Adafruit MLX90614 test");  

 mlx.begin();  
}

void loop() {
 Serial.print("Ambient = "); Serial.print(mlx.readAmbientTempC());
 Serial.print("*C\tObject = "); Serial.print(mlx.readObjectTempC()); Serial.println("*C");
 Serial.print("Ambient = "); Serial.print(mlx.readAmbientTempF());
 Serial.print("*F\tObject = "); Serial.print(mlx.readObjectTempF()); Serial.println("*F");

 Serial.println();
 delay(500);
}

J-M-L

Quote
i am doing a mlx90614 arduino project.
so my arduino mlx90614 project was working perfectly until some day ago in the serial monitor there is no temperature reading coming up.
what did you change or touch between some days ago and now?
Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums
Pas de messages priv├ęs SVP

pylon

Quote
my code and everything is fine but still there is no temperature reading. so can anyone help me what to do with this problem.
Why is everything fine if you don't get the expected result? I guess that the hardware changed in some way. It may be a broken wire, a bad breadboard contact or an overvoltage that slowly fried your chip. Without a wiring diagram and links to all used hardware we cannot help you further.

TomGeorge

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Check the IDE monitor and make sure the monitor speed is the same as your Serial.begin speed.

Tom... :)
Everything runs on smoke, let the smoke out, it stops running....

Go Up