Go Down

Topic: No such file or directory (Read 2419 times) previous topic - next topic


I'm trying to use Create to teach a class using UCtronics robots.  I originally purchased a robot in Juy and installed the librarys on my on create account with no problems.  When my students tried to install the librarys starting about 3 weeks ago they all got the following error

/tmp/646744694/MotorTest/MotorTest.ino:2:21: fatal error: UCMotor.h: No such file or directory

when they tried to verify or upload code that included UCMotor.h.  I have checked the installation of the librarys, and they look good.

I created my create account in January.  My students accounts were created between August and now.

The class only has chrome books, so using the computer based software is not an option.

Please help


There are quite a few reports of this issue with the Arduino Web Editor. Here are the ones I found after a quick glance:

So this is not really a Chrome App-specific issue but rather an Arduino Web Editor issue. The Arduino developers are looking into this. The latest word from them is that it only occurs for new users, which matches your experience of the problem not occurring for your account, but only for the students.


It was an error on our end. It should be solved now. Can you confirm?


It looks like I jumped onto a different thread. 

I am still having the problem.  It looks like my students create accounts are not able to add libraries.  I use the same file I used to successfully add the libraries to a stand alone version of the arduino software, but the create page will not add the libraries.

I am still getting the no such file or directory error.


Go Up