Go Down

Topic: Connect Arduino Uno R3 with ESP8266-12E and Blynk App (Read 78 times) previous topic - next topic

Alex8294

Hello to the community, I am new on the arduino idea. I am trying to find out how to connect the ESP8266-12E WiFi Module to my arduino uno. Well, the whole idea/project is: I have some sensors which i have already connected to my arduino and running smoothly (getting my readings correctly so far). I want to use the Blynk App to show the results. the problem that i am facing is that my wifi module isn't connected. However, when i programmed the ESP8266-12E to connect with the Blynk App it worked on switching on and off some LED lights. Unfortunately, the sensors didn't work on my ESP8266-12E but i didn't so furthure as this isn't my aim. I read loads of conversations and solutions online in various websites with no luck on it.
Just to mention that i flashed the ESP8266-12E with the AT Firmware. I have connected the ESP8266-12E to my wifi network (please see attached image). Now i am trying to load the AT commands for the ESP8266-12E through the arduino but i am facing an error on SoftwareSerial.h which i have it in the library btw. I think that if i include the AT commands in my program that already runs smoothly for my sensors on the arduino i can connect to the Blynk App (just an assumption).


If anyone in this community know or has good knowledge of this application please give some advises in order to make it work. (if i make this work i can continue to my furthure idea which might be intresting and ill upload the whole project so everyone can make it afterwards)



Thank you in advance



Kind Regards

Alex



P.S.

Its my first time that i post. if i did anything wrong or you need more information about the project let me know. Also how do i include the relative coding so who ever is going to help maybe can change something in my command?

pert

i am facing an error on SoftwareSerial.h which i have it in the library btw.
Don't you think it would be helpful to provide the error message?

When you encounter an error you'll see a button on the right side of the orange bar "Copy error messages". Click that button. Paste the error in a message here USING CODE TAGS (</> button on the toolbar).

Go Up