Go Down

Topic: I con not upload the file blink.pde to the Arduino Uno board (Read 1 time) previous topic - next topic

jack_lai

Apr 04, 2011, 03:51 am Last Edit: Apr 04, 2011, 03:57 am by jack_lai Reason: 1
I just bought a Arduino Uno board from Robotshop.com a few days ago. The order number is 88503.

I connect the Arduino Uno board by a standard USB cable( a printer cable).  After I connected it to a notebook computer. The greed LED turned on. and the L LED was blinking. ... I press the Upload button to upload blink.ped to the board. after about two seconds, The L LED turned off. then TX LED and RX LED turned on then turned off about two times. then, " Problem  uploading to board " appeared. but the message "Done uploading." did not appeared. then L LED again was blinking.  

my problem is:
can not upload the program blink.pde
to the board.


The following is the imformations

1.Your operating system:  
Vista

2.What kind of board you have.

Arduino Uno


3.Whether or not you were ever able to upload to the board. If so, what were you doing with the board before / when it stopped working, and what software have you recently added or removed from your computer?


This is the first time to use this board.  I download the software last month from
http://arduino.cc/en/Main/Software
I opened the file from
arduino-0022/example/Basics/Blink/blink.pde

the port is com4.

4. The messages displayed when you try to upload with verbose output enabled. To do this, hold down the shift key while clicking on the upload button in the toolbar.

Binary sketch size: 1018 bytes (of a 30720 byte maximum)
C:\Users\zhi hong lai\Documents\arduino-0022[1]\arduino-0022\hardware/tools/avr/bin/avrdude -CC:\Users\zhi hong lai\Documents\arduino-0022[1]\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\\.\COM4 -b57600 -D -Uflash:w:C:\Users\ZHIHON~1\AppData\Local\Temp\build8761977129823861310.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

        System wide configuration file is "C:\Users\zhi hong lai\Documents\arduino-0022[1]\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

        Using Port            : \\.\COM4
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 57600
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0xf9
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

baum

Do you have the right board selected?
Otherwise, I would like anyone else viewing this topic to look at this line:

Code: [Select]
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude obviously expected the 8u2 to repsond to some command with 0x14, but it instead got 0x51. Odd.


Other sources say this is cause by conflicting USB devices: make sure all other USB devices on your computer are unplugged/turned off before you upload again.

Senso

Did you installed the Uno drivers or the FTDI drivers?

baum

I though the Uno didn't have drivers? Bu Jack_lai can try upgrading the 8u2 firmware from arduino.cc

jack_lai

Thank you for the answers.
The problem I found.
I choosed the board to
"Arduino Uno"
then the board worked. ... then, "Done Uploading" displayed.
Before I choosed the board to
"Arduino Duemilanove or Nona w/ ATMEga328".
That was wrong.

baum

Yep. Choosing the wrong board will do that sort of thing.

Go Up