Go Down

Topic: Setting Yun board LEDs to default to off (WLAN & PHY) from openwrt? (Read 452 times) previous topic - next topic

satadru

I'm trying to figure out how to set the flashing blue WLAN led to be off programmatically.

It appears to be set to flash with WLAN activity, but even if I set the /sys files appropriately the lights come back on automatically.

Here's what I'm doing from rc.local:

Code: [Select]

echo none > /sys/devices/platform/ar933x_wmac/leds/ath9k-phy0/trigger
echo none > /sys/devices/platform/leds-gpio/leds/arduino\:blue\:wlan/trigger
echo 0 > /sys/devices/platform/ar933x_wmac/leds/ath9k-phy0/brightness
echo 0 > /sys/devices/platform/leds-gpio/leds/arduino\:blue\:wlan/brightness


And after boot this is what I see:
Code: [Select]

cat /sys/devices/platform/leds-gpio/leds/arduino\:blue\:wlan/brightness
255
cat /sys/devices/platform/leds-gpio/leds/arduino\:blue\:wlan/trigger
none switch0 [timer] default-on netdev usbport phy0rx phy0tx phy0assoc phy0radio phy0tpt

uci show system | grep "led"
system.@rngd[0].enabled='1'
system.@led[0]=led
system.@led[0].name='wlan'
system.@led[0].sysfs='arduino:blue:wlan'
system.@led[0].trigger='none'
system.@led[0].default='0'





I thought that maybe there might be something else setting those actions up, so I even tried delaying setting brightness to 0, but within a minute or two it comes back to 255.

I even tried to set the leds to have a trigger of none from luci, to tr

This is annoying since my Yun device is in my bedroom!

Any ideas on what I need to be changing? What program is turning the light back on?

I'm using the 17.11 prerelease, and I think I'm up to date otherwise.

Go Up