Go Down

Topic: software wount run on my mac. help!!! (Read 793 times) previous topic - next topic

Warwickben

i cant get the software to run on my mac. it starts bounces around then get this error log.i figure its some thing with java any helps iam a noob

Process:         JavaApplicationStub [461]
Path:            /Applications/Arduino.app/Contents/MacOS/JavaApplicationStub
Identifier:      cc.arduino.Arduino
Version:         0022 (0022)
Code Type:       X86 (Native)
Parent Process:  launchd [97]

Date/Time:       2011-04-06 08:39:36.849 -0400
OS Version:      Mac OS X 10.6.6 (10J567)
Report Version:  6

Interval Since Last Report:          215295 sec
Crashes Since Last Report:           5
Per-App Interval Since Last Report:  35 sec
Per-App Crashes Since Last Report:   6
Anonymous UUID:                      15EBFA6A-6214-4827-9B38-EAD4EDAC4B68

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x000000001ad6af6c
Crashed Thread:  3

Application Specific Information:

Java information:
Exception type: Bus Error (0xa) at pc=000000001ad6af6c

Java VM: Java HotSpot(TM) Client VM (19.1-b02-334 mixed mode macosx-x86)

Current thread (0000000003000800):  JavaThread "main" [_thread_in_native, id=-1332719616, stack(00000000b0105000,00000000b0905000)]
Stack: [00000000b0105000,00000000b0905000]
Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  apple.awt.CWindow.createNativeWindow(JIIIIZZLjava/awt/Font;Ljava/awt/Color;ZLjava/awt/Color;ZILjava/lang/String;IIZILjava/lang/String;IILjava/nio/ByteBuffer;ZF)J+0
j  apple.awt.CWindow.initPeer(J)J+1099
j  apple.awt.ComponentModel.initPeer()V+12
j  apple.awt.ContainerModel.initPeer()V+1
j  apple.awt.CWindow.initPeer()V+1
j  apple.awt.CFrame.create(Ljava/awt/Frame;)Lapple/awt/CFrame;+10
j  apple.awt.CToolkit.createFrame(Ljava/awt/Frame;)Ljava/awt/peer/FramePeer;+23
j  java.awt.Frame.addNotify()V+20
j  java.awt.Window.pack()V+28
j  processing.app.SerialMonitor.<init>(Ljava/lang/String;)V+698
j  processing.app.Editor.<init>(Lprocessing/app/Base;Ljava/lang/String;[I)V+68
j  processing.app.Base.handleOpen(Ljava/lang/String;[I)Lprocessing/app/Editor;+84
j  processing.app.Base.handleOpen(Ljava/lang/String;)Lprocessing/app/Editor;+6
j  processing.app.Base.handleNew()V+11
j  processing.app.Base.<init>([Ljava/lang/String;)V+298
j  processing.app.Base.main([Ljava/lang/String;)V+127
v  ~StubRoutines::call_stub
j  sun.reflect.NativeMethodAccessorImpl.invoke0(Ljava/lang/reflect/Method;Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+0
j  sun.reflect.NativeMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+87
j  sun.reflect.DelegatingMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+6
j  java.lang.reflect.Method.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+161
j  apple.launcher.LaunchRunner.run()V+76
j  apple.launcher.LaunchRunner.callMain()V+1
j  apple.launcher.JavaApplicationLauncher.launch(JJZ)V+11
v  ~StubRoutines::call_stub

Warwickben

this is what the console is telling me when i try to lunch the app.

any one got any idea how to fix this?


4/6/11 9:32:00 AM   [0x0-0x81081].cc.arduino.Arduino[701]   [JavaAppLauncher] Requested [1.5*], launching in [1.6] instead.
4/6/11 9:32:03 AM   [0x0-0x81081].cc.arduino.Arduino[701]   Invalid memory access of location 0x1ad6af6c eip=0x1ad6af6c
4/6/11 9:32:03 AM   com.apple.launchd.peruser.501[97]   ([0x0-0x81081].cc.arduino.Arduino[701]) Job appears to have crashed: Bus error
4/6/11 9:32:04 AM   ReportCrash[689]   Saved crash report for JavaApplicationStub[701] version 0021 (0021) to /Users/ben/Library/Logs/DiagnosticReports/JavaApplicationStub_2011-04-06-093204_benjamin-towles-mac-mini.crash

Go Up