Go Down

Topic: Arduino 0018 and 0022 not fully functional in Vista (Read 1 time) previous topic - next topic


I just received my Arduino Uno in the mail today and I can't seem to get a simple code to work.  I have a Vaio with Vista, and as far as I can tell, the drivers are installed.  In fact, the Arduino is recognized on COM17, which is fine, I suppose.  However, when I am inside of the Arduino IDE, I can't click on Tools.  I can write code, I can even drop down the menus to the left of Tools, however.  When I click on Tools, the IDE freezes up and won't unlock for about 3 or 4 minutes.  When it does, the Tools drop down menu is still not available.  So, basically, I can't tell the IDE which COM to write on, therefore, loading the code onto the Uno. 

Is it me, or is there something actually wrong with the Arduino software?  Would sure like to get a couple projects done. 




By the way, when I load the Arduino 0022 software (as well as 0018), I get en error message saying that the software could not be loaded..."Launch4j" was the title of the error message.  What the heck does this mean?  The software still loads a moment later after this error.  Load time, after restart, is still between 3 and 5 minutes.


I just added a note about this to the troubleshooting guide: "On Windows, if the software is slow to start or crashes on launch, or the Tools menu is slow to open, you may need to disable Bluetooth serial ports or other networked COM ports in the Device Manager. The Arduino software scans all the serial (COM) ports on your computer when it starts and when you open the Tools menu, and these networked ports can sometimes cause large delays or crashes."



WOW!  That seemed to work pretty flawlessly.  It's good that you explained it in that way, saying that the Arduino Software is looking for all COM Ports and perhaps causing the Application to time out. 

Basically, I disabled all COM ports that were listed in my Device Manager.  I also went the distance to disable any Bluetooth Network Adapters that I had, and when I opened the Arduino Software again, it booted in about 5 seconds.  More over, the Tools menu is working perfectly. 

Also, when uploading code to the Uno, I noticed before that I was having, saying that the port was already in use.  Having said that, after the changes that I made, it too was solved. 

Hopefully, if others are having this same crazy issue, they'll find this forum useful. 

Thanks again!

Go Up