Go Down

Topic: Problema led fade senza blocco delay (Read 301 times) previous topic - next topic

Silver70

Salve, premetto che da poco uso Arduino uno e mi trovo molto bene usando il delay.
Ultimamente mi è sorto un problema.
Vorrei accendere il led1 tramite fade ma allo stesso tempo vorrei che led2 inizi il suo ciclo di fade quando ad esempio led1 è a 50 faccio un esempio

for (int a=0;a<=255;a++){
analogWrite(led1,a);
delay(20)
senza chiudere la graffa apro un ciclo for preceduto da un if
if(a==50);
for (int b=0;b<=255;b++){
analogWrite(led2,b);
delay(20)
}
}
fino a qui tutto bene ma quando cerco di creare il fade out di entrambi funziona ma non come dovrebbe.
Si spengono in modo anomalo.
Ho letto che bisogna usare millis ma tra le tante spiegazioni che ho trovato quasi tutte accendono e spengono in modo digitale mentre io vorrei un fade analogico.
Spero di non aver creato confusione a chi vorrà gentilmente aiutarmi, un grazie in anticipo a tutti :)


gpb01

#1
Nov 22, 2018, 05:57 pm Last Edit: Nov 22, 2018, 06:00 pm by gpb01
Buonasera,
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ...

... poi, in conformità al suddetto regolamento, punto 7, devi editare il tuo post (quindi NON scrivendo un nuovo post, ma utilizzando il bottone More -> Modify che si trova in basso a destra del tuo post) e racchiudere il codice all'interno dei tag CODE (... sono quelli che in edit inserisce il bottone con icona fatta così: </>, tutto a sinistra).

In pratica, tutto il tuo codice dovrà trovarsi racchiuso tra due tag: [code] _il _tuo_ codice_ [/code] così da non venire interpretato e non dare adito alla formazione di caratteri indesiderati o cattiva formattazione del testo. Grazie. :)

Guglielmo

P.S.: Ti ricordo che, fino a quando non sarà fatta la presentazione, nessuno ti potrà rispondere, quindi ti consiglio di farla al più presto. ;)
Search is Your friend ... or I am Your enemy !

Claudio_FF

Quote from: Silver70
Ho letto che bisogna usare millis ma tra le tante spiegazioni che ho trovato quasi tutte accendono e spengono in modo digitale mentre io vorrei un fade analogico.
Immagino che hai già visto il recentissimo thread "millis su fade led rgb", li c'è tutto.
* * * * Una domanda ben posta è già mezza risposta * * * *

Go Up