Go Down

Topic: [WORKFLOW RELEASE] Vidor sample projects are opensource! (Read 5633 times) previous topic - next topic

jomoengineer

I ran into the build error as well and found I had to run through the following on Windows 10 64-bit to get a successful build:
NOTE: This was parsed from the vidor-libraries/VidorBitstream github repo under:
"Things to know before getting started"

1. Open the  NIOS II Command shell and set the PATH variable:
    $ PATH=$PATH:/cygdrive/h/Development/Arduino_config/MKR_Vidor_4000/fpga/VidorBitstream/TOOLS/scripts
    NOTE: This was valid for my config.

2. Then change directories to the VidorBitstream directory.
    NOTE: I did this from one directory up instead.
 
    $ cd /cygdrive/h/Development/Arduino_config/MKR_Vidor_4000/fpga/VidorBitstream/

    or

    $ cd /cygdrive/h/Development/Arduino_config/MKR_Vidor_4000/fpga

3.  Set the permissions to the files under VidorBitstream

    $ chmod -R a+rw *

4. Then under the TOOLS/scripts directory, run the patch script
   $ cd /cygdrive/h/Development/Arduino_config/MKR_Vidor_4000/fpga/VidorBitstream/TOOLS/scripts

   $ apply_quartus_patches.sh

5. Download and install the GO Programming language and build makeCompositeBinary.
   $ cd ../makeCompositeBinary
   
   $ go build -o makeCompositeBinary make_composite_binary.go

6. Build an example:
   $ cd /cygdrive/h/Development/Arduino_config/MKR_Vidor_4000/fpga/VidorBitstream/projects/MKRVIDOR4000_graphics

   $ build_all.sh

This resulted in the following for me:
Code: [Select]
Info: Quartus Prime Shell was successful. 0 errors, 352 warnings
    Info: Peak virtual memory: 4626 megabytes
    Info: Processing ended: Sat Jun 22 02:28:30 2019
    Info: Elapsed time: 00:06:33
    Info: Total CPU time (on all processors): 00:00:05
create ram + flash app.ttf
Jun 22, 2019 2:28:30 AM - (INFO) elf2flash: args = --input=build/software/MKRVIDOR4000_graphics/MKRVIDOR4000_graphics_lite.elf --output=build/output_files/MKRVIDOR4000_graphics_lite.flash --base=0x008E0000 --end=0x008FFFFF --verbose --save
Jun 22, 2019 2:28:30 AM - (FINE) elf2flash: Starting
Jun 22, 2019 2:28:30 AM - (FINE) elf2flash: Done
projects
ip
cp: omitting directory './ip/GFX/arduino/Vidor_GFX/examples'
cp: omitting directory './ip/QUAD_ENCODER/arduino/VidorEncoder/examples'
cp: omitting directory './ip/NEOPIXEL/arduino/VidorNeopixel/examples'
cp: omitting directory './ip/MIPI_RX_ST/arduino/VidorCamera/examples'




I hope this is on topic.

jomoengineer

After perfoming the VidorBistream build process and replacing the existing VidorGraphics Arduino IDE libraries folder with that built from VidorBitstream, ex;VidorBitstream\distrib\MKRVIDOR4000_graphics, as Martino explained to me has rendered my Vidor 4000 Graphics as non functional. I put the original library files back in place but still no luck; none of the VidorGraphics examples or code I had previously created and which were working are working now.  All I get on the HDMI output is a white screen with the Arduino log in the middle but not the one from the DrawLogo example.

jomoengineer

Okay, so I downloaded, built and loaded  VidorBoot from the vidor-libraries GitHub repro and all is right again with the Vidor 4000.   

Go Up