Go Down

Topic: WiFi Kit ESP-32 Bricked? (Read 582 times) previous topic - next topic

Val42

Nov 25, 2018, 01:16 am Last Edit: Nov 25, 2018, 03:49 am by Val42
I just received the Heltec WiFi Kit ESP-32 this week.  I've uploaded a few sketches, and they seemed to work.  I even uploaded the Blink sketch, and it worked.

However, even the Blink sketch no longer works when I upload it.  It seems to load correctly, but it doesn't work?  What else can I try?

O/S: Ubuntu 18/04
Kernel: 4.15.0-39-generic
Arduino IDE: 1.8.7
Board: Heltec_WiFi_Kit_32
Upload speed: 912600
Flash frequency: 80MHz
Port: /dev/ttyUSB0

I'm a professional programmer, but I haven't got to that point with the Arduino.  I tried changing the speed and flash frequency, to no avail.

I installed the board using https://dl.espressif.com/dl/package_esp32_index.json in preferences

It worked before I installed these libraries:
ESP8266 and ESP32 Oled Driver Driver for SSD1306 display (4.0.0)
U8g2 (2.24.3)
U8g2_for_Adafruit_GFX (1.5.2)

=====
Update 7:47 MST

I uninstalled everything then re-installed.  I also plugged the board into a port directly on the back of my computer.  Blink is working again.

But why would unrelated libraries kill the basic Blink program?

6v6gt


Go Up