Go Down

Topic: Installing drivers on arduino nano (Read 8146 times) previous topic - next topic

ChickenLittle

I made a really cool invention with the Arduino Uno but I want to make it smaller.  So I got a Arduino Nano and a really small breadboard and made the exact same thing with the Arduino Nano.  However, when I upload the code I wrote to the Nano the Arduino software said there was a problem uploading the code to the board and it gave me the name of a website.  The website basically said to install drivers.  Then I found a website that told me how to install drivers, https://www.arduino.cc/en/Guide/DriverInstallation.  I followed the instructions but when I get to the device managers listing of electronics I do not see Arduino Nano.

Please tell me how I can install drivers on the Arduino Nano.


Thanks so much.


 

ballscrewbob

#1
Nov 26, 2018, 04:32 pm Last Edit: Nov 26, 2018, 04:34 pm by ballscrewbob
What software told you to install driver ?
Where did it say to get them ?

Some Nano's use a CH340 driver or CP2102 which are NOT included in the IDE as they are for clones / copies of the Arduino.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

sterretje

Just a little correction

You do not install drivers on a Nano; you install drivers on a PC to support a Nano.
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

ballscrewbob

Quote
Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.
Stuck in a time loop I see ;)
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).

ChickenLittle

This is the error message I get after I upload the code.

Arduino: 1.8.3 (Windows 10), Board: "Arduino Nano, ATmega328"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\archi\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328 -ide-version=10803 -build-path C:\Users\archi\AppData\Local\Temp\arduino_build_995227 -warnings=none -build-cache C:\Users\archi\AppData\Local\Temp\arduino_cache_858877 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\archi\Documents\Arduino\My_Contest_Project_1\My_Contest_Project_1.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\archi\Documents\Arduino\libraries -fqbn=arduino:avr:nano:cpu=atmega328 -ide-version=10803 -build-path C:\Users\archi\AppData\Local\Temp\arduino_build_995227 -warnings=none -build-cache C:\Users\archi\AppData\Local\Temp\arduino_cache_858877 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\archi\Documents\Arduino\My_Contest_Project_1\My_Contest_Project_1.ino
Using board 'nano' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10803 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\sketch\My_Contest_Project_1.ino.cpp" -o "nul"
Generating function prototypes...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10803 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\sketch\My_Contest_Project_1.ino.cpp" -o "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\preproc\ctags_target_for_gcc_minus_e.cpp"
"C:\Program Files (x86)\Arduino\tools-builder\ctags\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\preproc\ctags_target_for_gcc_minus_e.cpp"
Compiling sketch...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10803 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\eightanaloginputs" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\sketch\My_Contest_Project_1.ino.cpp" -o "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\sketch\My_Contest_Project_1.ino.cpp.o"
Compiling libraries...
Compiling core...
Using precompiled core
Linking everything together...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p  -o "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.elf" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227\sketch\My_Contest_Project_1.ino.cpp.o" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/..\arduino_cache_858877\core\core_arduino_avr_nano_cpu_atmega328_0c812875ac70eb4a9b385d8fb077f54c.a" "-LC:\Users\archi\AppData\Local\Temp\arduino_build_995227" -lm
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0  "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.elf" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.eep"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -R .eeprom  "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.elf" "C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.hex"
Sketch uses 4852 bytes (15%) of program storage space. Maximum is 30720 bytes.
Global variables use 261 bytes (12%) of dynamic memory, leaving 1787 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM4 -b57600 -D -Uflash:w:C:\Users\archi\AppData\Local\Temp\arduino_build_995227/My_Contest_Project_1.ino.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM4
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: ser_open(): can't open device "\\.\COM4": The system cannot find the file specified.



avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Thanks so much.

ballscrewbob

#6
Nov 28, 2018, 12:10 am Last Edit: Nov 28, 2018, 12:13 am by ballscrewbob
CODE TAGS ( </> ) ?

Also please supply the output if you use the OLD BOOTLOADER option.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

ChickenLittle

When I use code tags I exceed the forums limit of 9000 characters.  But when you go into device manager do you install the drivers for: USB Serial port (com6) to have it upload to the board correctly.


Thanks so much.

pert

If it's on COM6 then you need to select Tools > Port > COM6 in the Arduino IDE.

ChickenLittle

The port is com 6 on the Arduino IDE

ChickenLittle

I think I install drivers on the one that says USB serial port com 6 because when I unplug the USB port connected to my project the one that says USB serial port com 6 disappears.  Am I right do I install drivers on the one that says USB serial port com 6.


Thanks so much.

ballscrewbob

The drivers do not care what the COM port number is.
Any items that use that same driver can be on a different port if they wish.
The driver is for the HARDWARE not the port number.

Quick example is your computer mouse.
You probably only installed one driver for it but you can plug it into other usb ports and it is still the same mouse...It just used the same driver on another usb port..

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

pert

If you have really do have Tools > Port > COM6 selected, then there's some glitch in the OS or the Arduino IDE. I remember a couple reports of this, but not what the resolution was. I recommend searching the forum and reading through the results until you find one:
https://www.google.com/search?q=avrdude+"can't+open+device"+site:http://forum.arduino.cc&domains=http://forum.arduino.cc&tbs=qdr:y,sbd:1&source=lnt&sa=X&biw=2144&bih=1206

sterretje

#13
Nov 28, 2018, 04:57 am Last Edit: Nov 28, 2018, 07:10 pm by sterretje
If the arduino is recognised as a COM port, there is no need to install the driver.

Did you try the 'old bootloader' option as suggested in reply #6 ?

By the way, the output that you posted refers to com 4.

PS
You also have 'verbose output during compilation' enabled. If you disable that, the output that you posted will be significantly shorter.

If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

ChickenLittle

When I tell it to update the driver for com 6 it says the best driver for the serial port com 6 is already on my computer.  What should the driver I install be.


Thanks so much.

Go Up