Go Down

Topic: Arduino 101 BLE verbindings probleem (Read 215 times) previous topic - next topic

MauriceBakker

hallo,

ik heb een arduino 101 in de garage om de verlichting en de temperatuur te regelen in de schuur.
ik maak daarbij verbinding met mijn telefoon via de blynk app.
dit werkt al een half jaar goed.
maar sinds de laatste maand kan mijn telefoon geen verbinding meer maken met de arduino 101.

de app zegt dan: kan geen verbinding maken. controleer of de auth. token correct is.

de auth token is goed. ik heb hem zelfs opnieuw in het programma gezet.
de BLE verbinding werkt zomaar uit het niets niet meer.

de arduino 101 draait op versie 1.0.7 (versie 2.0.2. heeft nog nooit gewerkt)
ik heb de nieuwste blynk library geinstalleerd v.0.5.4

dit is de sketch die ik gebruik voor de bluetooth verbinding:

#define BLYNK_PRINT Serial
#include <BlynkSimpleCurieBLE.h>
#include <CurieBLE.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "33ea2ffbf2bb464cb5ddfb49f1f25ab9";

BLEPeripheral blePeripheral;

void setup()
{
// Debug console
Serial.begin(9600);

delay(1000);

blePeripheral.setLocalName("Garage");
blePeripheral.setDeviceName("Garage");
blePeripheral.setAppearance(384);

Blynk.begin(blePeripheral, auth);

blePeripheral.begin();

Serial.println("Waiting for connections...");
}

void loop()
{
blePeripheral.poll();
Blynk.run();

}

kan iemand mij helpen om weer BLE verbinding te krijgen?

ik heb zelf het idee dat het komt door een update van de blynk app.
ik gebruik een samsung s6.

Go Up