Go Down

Topic: Uno R3 failing to upload (Read 146 times) previous topic - next topic

phildo

Nov 30, 2018, 02:11 am Last Edit: Nov 30, 2018, 04:53 am by phildo
Got a fresh Uno R3, hooked it up to some WS2811 LEDs- worked great.

Spoiler: it doesn't work great anymore, yes I've checked through the troubleshooting guide and have found nothing helpful.

WHAT HAPPENED:

The only connection between the LEDs and the Arduino was via the data pin & a shared ground (arduino was powered by 12v 1.5amp wall wart via barrel jack, LEDs powered by 12v 8amp brick via breadboard; ground on breadboard connected the power brick ground and arduino GND pin).

During transport from floor to desk (while everything is plugged in), the LED strip's ground wire dislodged from the breadboard (so it still was connected to the brick's power, but not its gound, and the data was connected to the arduino pin 5, and the arduino's ground was connected to the brick's ground).

I quickly unplugged everything from the outlet, and thought nothing of it.

THE CURRENT SITUATION:

When I plug in the arduino, the "L" LED and the "ON" LED light up- no flashing.
The board does show up in Tools when plugged in, as "/dev/cu.usbmodem14101 (Arduino/Genuino Uno)".
If I try to upload anything, I get

Code: [Select]
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
(it runs through all 10 tries)
Tx/Rx won't flash no matter what I do.

Any info I've found on this point to trying to hit the reset button at varying intervals before/after hitting the upload button- I've had no luck with this approach.

I have a different arduino that I accidentally plugged 12v into its 5v pin (mistakenly thinking the LED strip had two separate power lines... whoops) where it does not any longer show up in the Serial Port list, and I've tried swapping out the ATMega chips between them- neither responds any differently.

THE QUESTION:

Do you think the power lead on the LED strip, because it wasn't connected to ground, routed all of its power out of its data lead (and into the arduino whose ground was connected to its ground)?

If so, how would that harm the arduino?

Is there any method I can use to diagnose the specifics of what is wrong with both of my arduinos (so that I might swap out corresponding broken parts to make a functional frankenstein)?

Is there anything I can do to fix either arduino with the tools available to me? (Or will it need specific replacement parts?)

What can I do to stop this from continuing to happen?

Edit:
I just tried the loopback test on both of them, and neither appear to function. Not necessarily a surprise, but thought I'd add that info.

Go Up