Go Down

Topic: USB Blaster emulation (Read 779 times) previous topic - next topic

speccy

In Device Manager when I run the USB Blaster example sketch the device appear as "Arduino MKR Vidor 4000" with VID=09FB and PID=6001 which should correspond to the original USB Blaster device

I'm not able to get the USB Blaster driver to work with my Windows 10 PC.

I tried installing them manually from there : C:\intelFPGA_lite\18.1\quartus\drivers
and tried the method in the 2 following YouTube videos:
https://www.youtube.com/watch?v=yUNntuLeOwk
https://www.youtube.com/watch?v=qzTRw6xtZ3E


Any ideas?

DarioPennisi

Hi,
USB blaster support is experimental so there are a few things that may go wrong. In any case what you should check is the following:
1) we are slightly different than blaster as we expose a composite device with a serial port AND a USB blaster. Under windows, especially if you previously installed blaster drivers on your machine, the blaster driver may end up assigned to the composite device rather than to the blaster. In this case, to fix it, you have to uninstall the blaster driver checking the remove driver flag so that it won't autoinstall next time you plug it. Once this is done you should check in device manager you see both com port and the blaster and install driver only for the blaster. At this point it should work
2) Intel windows blaster driver is really picky so if you don't immediately and constantly call the loop function of the blaster library you may have issues as bad as a blue screen of death. Please check that you don't have any blocking call in your loop function
3) blaster works only with 64 bytes of endpoint size. We have the option to change this as on some Linux machines we saw that 64 would not work however scaling it down to 62 makes it work for some features but not everything
 We're still checking this and you may want to give it a try

Go Up