Go Down

Topic: Can't see output in the Serial Monitor with UNO Wifi Rev 2. (Read 622 times) previous topic - next topic

jparkerri

I am able to compile and upload the Blink test sketch and run it successfully on my new UNO Wifi Rev 2.  I have the correct board and port loaded. However with any sketches that have Serial.print commands, I don't see any output in the Serial Monitor.  I've tested using different baud rates and even Serial1 and Serial2 even though they shouldn't work. 
The simple sketch runs fine on a Mega2560 and an original UNO Rev3.
Any suggestions?
Using:
void setup() {
  Serial.begin(9600);
  Serial.println("Running Setup ...");
}
void loop() {
  Serial.println("In loop ...");
  delay(1);
}

TheNetStriker

I am able to compile and upload the Blink test sketch and run it successfully on my new UNO Wifi Rev 2.  I have the correct board and port loaded. However with any sketches that have Serial.print commands, I don't see any output in the Serial Monitor.  I've tested using different baud rates and even Serial1 and Serial2 even though they shouldn't work.  
The simple sketch runs fine on a Mega2560 and an original UNO Rev3.
Any suggestions?
Using:
void setup() {
  Serial.begin(9600);
  Serial.println("Running Setup ...");
}
void loop() {
  Serial.println("In loop ...");
  delay(1);
}
I am also having problems with the usb serial port. When using a third party serial port monitor I also often cannot see anything from the serial port. And when using the Arduino IDE serial monitor I get strange encoding problems. I opened a thread for my problem here: http://forum.arduino.cc/index.php?topic=591498.0

Do you habe similar problems with your hardware?

Go Up