Go Down

Topic: Cant get Arduino NANO clone to work (Read 766 times) previous topic - next topic


i have some trouble with an arduino nano clone(i asume). It has the ch430 chip i already installed the drivers, but i cant get any sketch to it over the arduino ide, nor flash the new bootloader. Error was device signature 0x00000

So i startet googling around and found an arduinoISP programmer sketch with a clock output on pin3, which i uploaded to a working uno. then i tried to burn the bootloader on the arduino nano with the arduino ide and nothing. Clock out was conected to arduino xtal1.

Then i tried the same manualy with avrdude and it worked. i uploaded the arduino bootloader (hex file) to the nano and the led blinks. now my problem is that the leds only blinks if i have a clock signal conected to the xtal 1 pin. as soon as i remove it it stops working.

so i checked the fuses and changed them to
lfuse 0xff
hfuse 0xda
efuse 0x05

still only works with an clock signal to xtal1. i still cant upload any sketch with arduino ide.
Please some help


It sounds to me like you have a bad Nano where the resonator by the D5 and D6 pins fell off, or is otherwise bad.  You did excellent troubleshooting/investigation.  

If you set the low fuse to E2 it will run on the internal oscillator and you can upload sketches to it using the Upload Using Programmer function, which uses you externally-attached Arduino as ISP programmer.   It will run at 8MHz, same speed as a LilyPad (select LilyPad Arduino as the board type in the IDE when uploading a sketch).   You may be able to get USB serial uploading to work, but I don't have a lot of faith in serial with internal oscillator because the frequency will fluctuate.  

Or you can repair the Nano if you have another resonator laying around, such as from another Nano that you burned out another component.   Or you can toss this Nano into a pile of bad boards that you can cannibalize parts off of in the future.   

Note that Nick Gammon's bootloader sketch can load a bootloader and set the fuses for internal oscillator if you select L for LilyPad.   To find out more about Nick's sketches and web page, visit http://www.gammon.com.au/bootloader


Thanks a lot,
i got it running on the internal oscillator, using the arduino ide "Atmega328 on breadboard (8MHz internal clock)", to compile and the "upload using programmer" to upload.

tested with the blink sketch on multiple ports.

The physical resonator is there on the nano, maybe it has a cold solder point or is dead.

But anyways this arduino was ment to get some code that later on would be used in a "breadboard project with the atmel" so i guess there is some karma or strange thing going on here .... not (But the breadboard project is true, lol)

Thanks again

Go Up