Go Down

Topic: Catalex SD module and Mega -- issue detecting card (Read 1 time) previous topic - next topic

Devilstower

I'm using a Catalex MicroSD module with an Eelegoo Mega2560. I had previously wired this combination up and made a little data logger that seemed to work fine, but now I'm back to square one and I'm buffaloed.

I understand that the Catalex can hog SPI, but I was able to work around that before and it's not the issue here. I'm back to the fundamental "darn it, why doesn't it see my card?"

I have the Catalex wired up as suggested by the standard pins for an SD module on a Mega:

** MOSI -- 50
** MISO -- 51
** CLK (SCK on the Catalex) -- 52
** CS -- 53  

I've gradually stripped everything away other components until that's all that's left, and I've ditched my own code and gone back to using CardInfo and other SD examples. But regardless of the code, I get some variation on "Card failed, or not present."  I've checked the wiring, reformatted the SD card, and even opened the envelope on another Catalex module, but I'm still getting the same issue.

What fundamental, newcomer idiocy am I committing this time? Thanks.

Juraj


Devilstower

Yes. CardInfo and other examples.

CardInfo returns "Initialization failed."  Other SD examples return "Card failed, or not present."

Devilstower

In the spirit of trying to eliminate all potential issues, I tried another Micro SD. No difference.

Then I dragged out a Elegoo Nano, wired it up to one of the Catalex SD modules, and got this conflicting info...

14:29:41.250 ->
14:29:41.250 -> Initializing SD card...Wiring is correct and a card is present.
14:29:41.250 ->
14:29:41.250 -> Card type:         SD2
14:29:42.762 ->
14:29:42.762 -> Initializing SD card...initialization failed. Things to check:
14:29:44.869 -> * is a card inserted?
14:29:44.902 -> * is your wiring correct?
14:29:44.902 -> * did you change the chipSelect pin to match your shield or module?

So .... Hmm.

Devilstower

And ... more weirdness. After getting the value above, I decided to practice my soldering by blowing $6 and moshing together a Nano and the SD module.

After I completed this, I tried CardInfo again and got ...

15:41:39.342 -> Initializing SD card...Wiring is correct and a card is present.
15:41:39.410 ->
15:41:39.410 -> Card type:         SD2
15:41:39.951 -> Could not find FAT16/FAT32 partition.
15:41:39.985 -> Make sure you've formatted the card

That seemed like progress, so I downloaded the official SD Card formatter and formatted the card in clean, new FAT 32. Put it back in and got ...

15:41:22.830 -> Initializing SD card...initialization failed. Things to check:
15:41:24.970 -> * is a card inserted?
15:41:25.003 -> * is your wiring correct?
15:41:25.003 -> * did you change the chipSelect pin to match your shield or module?

And ... yeah. Extremely frustrating.


Juraj


Devilstower

#6
Jan 01, 2019, 07:09 pm Last Edit: Jan 01, 2019, 07:25 pm by Devilstower
That sounds nice, but it doesn't match what I see in the library or on other threads.

** MOSI - pin 11 on Arduino Uno/Duemilanove/Diecimila
** MISO - pin 12 on Arduino Uno/Duemilanove/Diecimila

** MOSI - pin 50 on Arduino Mega
** MISO - pin 51 on Arduino Mega

It's also not what I had wired up when it was working.

Though ... when I look around, I see examples that are -both ways-. Which is ... arggh.

However, it's not solving my issue in either case. With MISI / MISO on 51 / 50, I get the card not detected error. With MISI / MISO on 50 / 51 I get the "Wiring is correct" message, followed by an error that the card isn't formatted ... though it is. In fact, I've gone through trying two catalex boards, a whole series of micro SDs from 4G to 16G, and both FAT16 and FAT32 formats. But I've still be unable to correctly read / writer a card.

Now, if I only had a spare MEGA, so I could test that part.

Juraj

https://www.arduino.cc/en/tutorial/arduinoISP#toc3

https://store.arduino.cc/arduino-mega-2560-rev3
Quote
SPI: 50 (MISO), 51 (MOSI), 52 (SCK), 53 (SS). These pins support SPI communication using theSPI library. The SPI pins are also broken out on the ICSP header, which is physically compatible with the Arduino /Genuino Uno and the old Duemilanove and Diecimila Arduino boards.

Devilstower

I'm rather suspecting that the problem lies on another level -- I'm afraid that my basic ignorance I burned these little modules up with too much voltage.

A learning process all around.


And thanks, BTW. Using the right pins at this point isn't helping, but I believe it's because I've put myself beyond help until I get another module.

Go Up