Go Down

Topic: What happened to the leonardo? My USB has gone. (Read 574 times) previous topic - next topic

TheKizz

Hoping this is int correct part of the forum.
Hoping this is not a common repeated question.

I used a Leonardo to make a simple joystick Button Box for driving games on the PC. Now I cannot find the Arduino File in my examples that I used. modified and it worked well. Just plugged the usb into the PC and the box was recognised as a HID device. Windows saw it as a USB game controller.
Please can someone point me to the correct location I should now be using. 
Asking questions is easy, finding the right person to ask, at the right time, is insanely complicated.

TheKizz

It seems to be that " You must select Joystick from the "Tools > USB Type" menu" is no longer an option. I even loaded  a previous version (1.8.7), yet it seems to have gone astray... what... I understand you may have moved on, but archive version always held... now I am deeply disappointed. Anyone any idea how we can go forward with a project that used to be recognised as a game device in the list of USB item?
Asking questions is easy, finding the right person to ask, at the right time, is insanely complicated.

pert

Also posted at:
https://forum.pjrc.com/threads/54806-lost-setting-Tools-USB-Type-from-Arduino-Menu
If you're going to do that then please add links to the other places you posted. This will let us avoid wasting time due to duplicate effort and also help others who have the same questions and find your post to discover all the relevant information. When you post links please always use the chain links icon on the toolbar to make them clickable.

In that thread, you report that you've gotten to this point:
Quote
I re-downloaded the Teensy Loader, and used it to install Fast blink and then when that was in and blinking, slow blink. Ok, so the Teensy ++ is connected to the PC and is communicating with the teensy loader.
I downloaded the latest build of Arduino, now (1.8.9 )
Checked libraries again and still no sign of teensy boards, so am unable to tell the arduino software that a teensy board is on the end of the USB cable.
I am really certain that I found Teensy under examples in its own group following the arduino listings examples... well its aint there on my windows 10 PC. The adafruit playground is there... Any help Paul would be very appreciated. Let me know what you want in the screen shot, I'm in UK so go to bed around 11 pm, about 45 minutes after posting this.
Cheers.
Quote
Hi, Yes, I have downloaded the current teensy loader ( see one of my replies) and the latest copy of the arduino software (see above reply). Board is Teensy++ and loads fast blink and then slow blink from the teensy loader, so now I'm flummoxed.
The 1.8.9 version of the Arduino IDE you're using is the hourly build. That version is only intended to be used for beta testing. You should uninstall that version and instead install Arduino IDE 1.8.8, downloaded from here:
http://www.arduino.cc/en/Main/Software
After that, download and install Teensyduino from here:
https://www.pjrc.com/teensy/td_download.html
After that, your problem should be solved.

Go Up