Go Down

Topic: Unable to burn bootloader (Read 21810 times) previous topic - next topic


Jan 10, 2019, 12:37 am Last Edit: Jan 10, 2019, 12:43 am by odendaaltje Reason: typo
Can anyone help me, I've searched the internet for a couple of days and I found some people with the same issue, but I can't figure out how to solve this.

I can't burn the bootloader to my atmega 328P chip, anymore. I did this a couple of times in the past, but now I keep getting these errormessages. Error messages see below.

I have tried:
another USB cable;
another chip;
another computer;
another (older) Arduino IDE;
I have hooked up everything again;
I have edited the signature in avrdude.conf

So... I am getting a bit of a headache now. :smiley-confuse:
Any help is highly appreciated  


Arduino:1.8.8 (Mac OS X), Board:"Arduino/Genuino Uno"

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.usbmodemFD141 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

avrdude: Version 6.3-20171130
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2014 Joerg Wunsch

        System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
        User configuration file is "/Users/odendaal/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/cu.usbmodemFD141
        Using Programmer              : arduino
        Overriding Baud Rate          : 19200
        AVR Part                      : ATmega328P
        Chip Erase delay              : 9000 us
        PAGEL                         : PD7
        BS2                           : PC2
        RESET disposition             : dedicated
        RETRY pulse                   : SCK
        serial program mode           : yes
        parallel program mode         : yes
        Timeout                       : 200
        StabDelay                     : 100
        CmdexeDelay                   : 25
        SyncLoops                     : 32
        ByteDelay                     : 0
        PollIndex                     : 3
        PollValue                     : 0x53
        Memory Detail                 :

                                 Block Poll               Page                       Polled
          Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
          ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
          eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
          flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
          lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
          hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
          efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
          lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
          calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
          signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

        Programmer Type : Arduino
        Description     : Arduino

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x02

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x10
        Hardware Version: 425479
        Firmware Version: 8430084.-1451020460
        Topcard         : STK502
        Vtarget         : 1.8 V
        Varef           : 0.0 V
        Oscillator      : Off
        SCK period      : 0.1 us

avrdude: stk500_initialize(): (b) protocol error, expect=0x10, resp=0x01
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x10

avrdude done.  Thank you.

Fout bij het branden van de bootloader.


What type of ISP programmer are you using, and how are you connecting it? Can you post a schematic of your connections?


Any help is highly appreciated
Try a 10uF capacitor between Reset and Gnd on the Arduino used as ISP.


Jan 10, 2019, 09:43 am Last Edit: Jan 10, 2019, 09:45 am by Budvar10
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.usbmodemFD141 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xDE:m -Ulfuse:w:0xFF:m

The switch -cArduino is an indication for capacitor use as @kprims wrote, or try to use this command with -cstk500v1 from the CMD.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0


Thanks to you all!
 I'll try the capacitor.
But I wonder how can that suddenly be necessary... I never used one in the past?

I used an Arduino Uno as the programmer. I have attached a photo of my breadboard and a frtzing scheme.
I also have added a led as you can see.

I'll let you all know what happens if i plugin the capacitor... tomorrow.


In Arduino AVR boards 1.6.22, Arduino changed the protocol used by the Arduino as ISP programmer from stk500v1 to arduino. This was done to allow the use of the ATmega32U4 boards for Arduino as ISP on Windows but it also made it more likely that the auto-reset capacitor would now be needed on boards that previously worked without. You could test whether this is the source of the problem by using Boards Manager (Tools > Board > Boards manager) to roll back your Arduino AVR Boards version to 1.6.21, then try burning the bootloader.

To fix this issue, I have reverted the Arduino as ISP programmer definition back to using the stk500v1 protocol and added a new Arduino as ISP (ATmega32U4) programmer that uses the arduino protocol. That change will be in the next release of Arduino AVR Boards.



Thank you pert!
I installed the previous version as you said 1.6.21 (I had the 1.6.23) and...
burning the bootloader was successful!!!

I am very happy now.
The next one I need to bootload I'll try the capacitor, or do as Budvar10 told me.

Thanks everyone for your quick reply's.


Go Up