Go Down

Topic: Adafruit Winc1501, using Wifi101, will not connect via WPA(2) (Read 507 times) previous topic - next topic

semmett

I'm using the Wifi101 library.  When I run the ScanNetworks (or ScanNetworksAdvanced) sketch I get the following output:

MAC: F8:F0:05:A6:03:0E
Scanning available networks...
** Scan Networks **
number of available networks:3
0) Betelgeuse   Signal: -38 dBm   Encryption: WPA
1) Pollux   Signal: -38 dBm   Encryption: None
2)    Signal: -59 dBm   Encryption: WPA

It's what I expect.

When I run the "ConnectNoEncryption" sketch using the Pollux network, i can successfully connect.

Attempting to connect to open SSID: Pollux
You're connected to the networkSSID: Pollux
BSSID: 86:D2:94:2D:F3:B5
signal strength (RSSI):-38
Encryption Type:1
IP Address: 192.168.1.24
192.168.1.24
MAC address: F8:F0:05:A6:03:0E
NetMask: 255.255.255.0
Gateway: 192.168.1.1

When I run the "ConnectWPA" sketch using the Betelgeuse I repeatedly get "Attempting to connect to WPA SSID: Betelgeuse"  messages.

Checking the router log (its and Orbi RBR50 with one satellite) I see the error message

"[WLAN access rejected: incorrect security] from MAC address f8:f0:05:a6:03:0e"

So I check the "arduino_secrets.h" sketch tab and the correct SSID and password are in the appropriate #defines with the correct capitalization and spacing in the SSID and password.

I've looked in the Wifi101 library for methods that may exist to help in troubleshooting this problem but can't find any.

Any comments, questions, suggestions that might help to resolve this are greatly appreciated.

TNX

semmett

I just tested the Wifi101 library against a Netgear WNDR4500v3 router.  Different SSIDs, different passwords.  The Wifi101 scanning sketch returns the correct network SSID.  The ConnectWPA sketch fails.

Issue appears to be with either the WINC1500 or with the library.

The project I was working on will now have to be moved from to Raspberry Pi. 

semmett

Problem resolved.  Its an issue with the firmware version that comes with the WINC1500.  It needs to be updated from 19.4.4 to 19.5.4.  You can easily do that but you have to use an older version of the Arduino IDE.  I used 1.8.6 and the firmware update went swimmingly.  after that the ConnectWPA works correctly.

Go Up