Go Down

Topic: Only getting one handshake between telemetry radios (Read 230 times) previous topic - next topic

tristan1473

Jan 21, 2019, 12:19 am Last Edit: Jan 21, 2019, 12:23 am by tristan1473
I have a Holybro 433 MHz transceiver radio pair (datasheet link attached) which are wired to an Arduino Mega 2560 and an Arduino Pro Mini. These transceivers use the HopeRF Library which comes with examples that send a char string to the other transceiver and a string is sent back. These do this about once a second and every time I either restart the serial monitor on the 'client' or cycle power on the 'server' there is one handshake and then they will not communicate with one another any additional times. I have included the scripts, the problem seems to be with using the Arduino Pro Mini instead of the Arduino Mega, as it was working well with two Arduino Megas. It should be wired correctly because there is at least one handshake but the transceiver on the Pro Mini is wired to its RX/TX pins, so it seems to be a coding issue; perhaps timing. Appreciate any help, thanks.


http://www.holybro.com/manual/Telemetry-Radio-V3-Quick-Start-Guide.pdf
https://cdn.sparkfun.com/datasheets/Dev/Arduino/Boards/ProMini16MHzv1.pdf


jremington

#1
Jan 21, 2019, 02:50 am Last Edit: Jan 21, 2019, 03:06 am by jremington
Quote
the transceiver on the Pro Mini is wired to its RX/TX pins
It won't work to use those pins for the serial monitor and a transceiver at the same time, so how are you handling that?

The posted code should not compile for a Pro Mini, because it lacks Serial1.

tristan1473

I am only viewing the serial monitor from the Mega where the following is printed

sending
got: reply
sending
sending
sending
...

which the Mega is acting as the client and the Pro Mini the server. I had used an FTDI cable to upload the script to the Pro Mini so it is not being monitored through the PC and that 'Serial1' had been changed to 'Serial' in the existing code, sorry about that.

jremington

#3
Jan 21, 2019, 04:44 pm Last Edit: Jan 21, 2019, 04:46 pm by jremington
For informed help, post the code about which you are actually asking the questions.

Quote
Serial1' had been changed to 'Serial' in the existing code
As you have discovered, that does not work. With the Pro Mini, you have to use some version of software serial for the radio. Beware the limitations of Baud rate.

Go Up