Go Down

Topic: MKR NB 1500 - no own sub forum and problem with connection (Read 816 times) previous topic - next topic

solick

Hi all,

I just received my MKR NB 1500 and tried to get it running.

First: There is no own sub forum für the MKR NB 1500 so I post my question here. Sorry if this is not the right place.

I got my MKR NB 1500 connected and can work with it but the example for scan network does not work because nbAccess.begin always returns ERROR.

Does anyone has an idea what the root problem could be?

Unfortunately the debug mode seems not to work properly. I created the object with the debug flag but still don´t see any AT commands as promised.

michaelm66403

Hi, I also posted in the MKR1400 forum that we need a sub-folder for the 1500.  :-)

I just got my 1500 last week -- using Hologram SIM on AT&T network.


Try these before your setup() -- this should get things going for you, hopefully.


#include <MKRNB.h>

NB nb(1);  // 1 = debug mode - shows AT commands.
NBClient client;
GPRS gprs;


sejersbol

Hi,

I'm having the same problem. I have added the debug mode, but nothing is returned. I can load the sketch, but nbAccess.begin("") never return NB_READY :-( (My SIM does not have a PIN.)

The weird thing is, I tried to run the https://www.arduino.cc/en/Tutorials/NBRATConfig sketch. This worked and I selected 1 for NB-IoT only (I'm in Europe). No problems, but it took about a minute for configuration to complete. When I try to run the NBRATConfig sketch again it NOW does NOT WORK and MODEM.noop() never returns true! (Never continues beyond "while (!MODEM.noop());")

I have tried the SIM on a different NB-IoT modem where it worked.

Can I check if the board/modem is somehow broken?

I'm kind of lost here - any help would be highly appreciated.


Kind regards,

Anders Sejersbøl.

hs_soni

same problem here.
Only Arduino portion of board working. Spent a lot of time experimenting on this board, but no success. Giving it a pause...
Appreciate if some one can show the light


Have ordered Pycom FiPy for my NB project.

regards//Harjeet

jdubosejr

Were can I find a get started guide for the mkr nb 1500?


habi308

Hi, I am getting verry close to get it to work with my 1NCE-SIM - is this the correct NB 1500 Forum to share my config?

pert

I think it's a reasonable place to share it. Thanks!

habi308

Hi, I used SerialSARAPassthrough example to set TCPIP parameters

        Serial.println("m: configure parameters TCPIP");
        SerialSARA.println("AT+QICSGP=1,1,\"iot.1nce.net\",\"\",\"\",1");
        break;


In advance I used ChooseRadioAcceessTechnology.ino to set "NB IoT only".

This is my resulting config:

        Serial.println("f: Display current configuration");
        SerialSARA.println("AT&V");

21:22:00.527 -> f: Display current configuration
21:22:00.527 -> AT&V

21:22:00.527 -> ACTIVE PROFILE: &C: 1; &D: 1; &F: 0; Q: 0; V: 1; X: 1; Z: 0; &S: 1;
21:22:00.527 -> &W: 0; \Q: 3; E: 1; L: 0; M: 0; &K: 3; &Y: 0; O: 0; S0: 0; S4: 10; S5: 8;
21:22:00.573 -> S6: 2; S7: 0; S8: 2; S10: 14; S3: 13; S2: 43; S12: 50; +ICF: 3,1;
21:22:00.573 -> +IFC: 2,2; +IPR: 115200; +CMEE: 2; +WS46: 12; +CFUN:; +UAUTHREQ: 1,0,"";
21:22:00.573 -> +CEREG: 0; +CEMODE: 2; +CSCS: "IRA"; +CRC: 0;
21:22:00.573 -> +CGDCONT: (1,"IP","iot.1nce.net","0.0.0.0",0,0,0,0); +CGDSCONT: ;
21:22:00.573 -> +CGEREP: 0,0; +CGSMS: 1; +CSMS: 0; +CMGF: 0; +CSAS: 0; +CRES: 0;
21:22:00.573 -> +CSCA: "",; +CSMP: ,,0,0; +CREG: 0; +CGREG: 0; +CGPIAF: 0,0,0,0;
21:22:00.573 -> +CSDH: 0; +CPIN: ⸮⸮⸮⸮⸮⸮⸮⸮,⸮⸮⸮⸮⸮⸮⸮⸮; +CMER: 0,0,0,0,0;
21:22:00.573 -> +CPMS: "ME","ME","ME"; +CNMI: 0,0,0,0,0; +CMMS: 0; +COPS: 1,0,"";
21:22:00.619 -> +CGATT: 1; +CGACT(1,1); +CPOL: 0,2,"",0,0,0,0; +CPLS: 0; +CTZR: 0;
21:22:00.619 -> +CTZU: 1; +CSDF: 1; +CUSD: 0; +CIND: 5,2,1,0,0,1,1,0,1,0,0,0;
21:22:00.619 -> +CPSMS: 0,"","","",""; +CEDRXS: 0,1,""; +URAT: 0,0; +UMNOPROF: 0;
21:22:00.619 -> +UPSV: 0,0
21:22:00.619 ->
21:22:00.619 -> OK



Now its connectiong to T-Mobile / Germany with NB-IoT :-)


Tjalfi

Hello,

i've got the same problem, as you, also with 1nce.
Could you please post a complete sketch for your solution? I can't it working, even when setting all parameters as you have...
Thank you very much!

Go Up