Go Down

Topic: erreur de téléchargement sur une carte ESP32 (Read 423 times) previous topic - next topic

CHBR94

Bonjour,

J'ai acquis une carte Adafruit ESP 32 Feather dans le but de pouvoir la programmer dans l'ide arduino.
https://www.adafruit.com/product/3405

Dans l'ide arduino je suis allé dans préférence, et dans les paramètres je suis allé dans l'url de gestionnaire de cartes supplémentaires et j'ai tapé:https://dl.espressif.com/dl/package_esp32_index.json


Pour finaliser l'installation, je suis allé dans "outils" puis "type de carte" puis dans "gestionnaire de cartes".
Normalement, je devrais trouver la librairie correspondante à ma carte mais elle ne s'y trouve pas.
Dans le bas de la fenêtre de gestionnaire de carte est écrit en rouge:
Erreur durant le téléchargement de https://downloads.arduino.cc/packages/package_index.json

Pour remédier au problème, j'ai supprimé l'ide pour réinstaller la nouvelle version (j'ai la version  1.8.9).
Mais rien n'y fait. J'ai toujours se problème d'erreur.

Si quelqu'un à une idée pour résoudre mon problème???

En plus, dans la partie programmation de l'ide, dans la vérification de la compilation tout un tas d'explication est indiqué en rouge. Je le met à titre d'information mais c'est assez long:

Erreur durant le téléchargement de https://downloads.arduino.cc/packages/package_index.json
java.lang.RuntimeException: java.lang.Exception: Erreur durant le téléchargement de https://downloads.arduino.cc/packages/package_index.json
   at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:150)
   at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: Erreur durant le téléchargement de https://downloads.arduino.cc/packages/package_index.json
   at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:139)
   at cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:333)
   at cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:307)
   at cc.arduino.contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:285)
   at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$1(ContributionManagerUI.java:146)
   ... 1 more
Caused by: java.nio.file.FileSystemException: C:\Users\Perso\AppData\Local\Arduino15\package_index.json.tmp: Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus.

   at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:86)
   at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
   at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
   at sun.nio.fs.WindowsFileSystemProvider.implDelete(WindowsFileSystemProvider.java:269)
   at sun.nio.fs.AbstractFileSystemProvider.delete(AbstractFileSystemProvider.java:103)
   at java.nio.file.Files.delete(Files.java:1126)
   at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:156)
   at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:132)
   at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:137)
   ... 5 more


Cordialement,



lesept

Quote
Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus.
On dirait un problème d'accès multiple à ce fichier. Essaie de rebooter ton PC.

As-tu relancé l'IDE avant de compiler ?
A force d'essayer on finit par réussir... Donc, plus ça rate, plus on a de chances que ça marche (proverbe Sharduinok).

CHBR94

Oui, j'ai relancé plusieurs fois l'ide.
Non effectivement, je n'ai pas relancé le PC.
Je le fais tout de suite.

CHBR94

Le problème persiste.
Cependant, j'ai déjà essayé de supprimer les fichiers de la librairie sans redémarrer l'ordi. Je vais donc tenter de supprimer les fichiers téléchargés, de redémarrer l'ordi et de reprendre une nouvelle installation.

CHBR94

Pas de changement. J'ai repris l'installation depuis le début et le même message d'erreur s'affiche.


lesept

#5
Mar 19, 2019, 09:11 pm Last Edit: Mar 20, 2019, 07:21 am by lesept
C'est pas un problème d'installation avec droits admin et utilisation sans ces droits ?
A force d'essayer on finit par réussir... Donc, plus ça rate, plus on a de chances que ça marche (proverbe Sharduinok).

hbachetti

Caused by: java.nio.file.FileSystemException: C:\Users\Perso\AppData\Local\Arduino15\package_index.json.tmp: Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus.

Ce fichier existe t-il ?
Le répertoire Arduino15 est-il accessible en écriture ?
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

CHBR94

Merci à lesept pour son proverbe Sharduinok qui s'est révélé une fois de plus exact et merci à hbachetti qui m'a mis dans la bonne direction.

Pour régler mon problème j'ai procédé comme indiqué:

1/ Pour trouver le fichier défectueux, j'ai ouvert l'ide arduino, cliqué sur l'onglet "fichier", puis sur "préférences". Ensuite il faut suivre l'arborescence indiqué dans la fenêtre "Préférences" situé sous le champ ou j'ai collé l'URL. Pour cela j'ai double cliqué sur le lien quant-il devient bleu. Pour moi c'est: C:\Users\Perso\AppData\Local\Arduino15\preferences.txt

2/ La fenêtre d'exploration windows s'affiche avec tous les fichiers index.json, index.json.sig, index.json.sig.tmp et .txt. J'ai supprimé tous ces fichiers, et fermé l'ide arduino.

3/Ré-ouverture de l'IDE et j'ai repris l'installation depuis le début.

Conclusion: J'ai un portable sous windows 7 et j'ai chargé le programme en wifi. Je pense que le problème vient du premier téléchargement des dossiers nécessaire à l'installation de la carte ESP32.

A+ et merci

Go Up