Go Down

Topic: Sobrecalentamiento de la placa por la fuente externa (Read 323 times) previous topic - next topic

Noarodriguez

Buenas,
Desde hace unos 6 meses dispongo de un Arduino Mega, con el que he hecho diversos proyectos pero siempre con la alimentación mediante USB. Para este nuevo proyecto necesito aplicar tensiones mayores que 5V, así que decidí usar la alimentación externa con 12V y 0.8A.
El problema es que cada vez que conecto la alimentación, en menos de un minuto se sobrecalienta un montón. El regulador de tensión es AMS1117 5.0

Me gustaría saber si estoy haciendo algo mal, o si simplemente se tiene que cambiar algún componente.
Gracias.

tauro0221

Hi,
Para mi el uso de una energia de 12 voltios va calentar el regulador. Ya que el regulador que este en la tarjeta no tiene un buen disipador de calor. Mi sugerencia es la de bajar el voltaje de 9 voltios.Otra cosa que debes de tener tambien en cosideracion es si usas los 5 voltios del mega para suplir energia a componentes externo. El  maxima dr corriente que puede suplir el regulador del mega es como de 800ma y si estas supliendo cerca de los 800ma se va a calentar.

Noarodriguez

Vale perfecto, voy a alimentar Arduino 2V por encima de los 5V, a unos 7. Pero lo de los miliamperios no lo termino de comprender, es decir, yo creía que como más grande fuera la corriente, más componentes se le pueden conectar a Arduino. Hay posts en los que dicen haber llegado al menos a 1600 mAh con baterías LiPo para alimentarlo. Pero usted está comentado que la máxima corriente es de 800mAh.


También tengo otra duda, en algunas páginas dice que Arduino Uno solo es capaz de suministrar hasta 500 mA, y en otras que solo puede entregar 200mA máximo. ¿ En que quedamos?


Realmente estoy intentando encontrar el modo más efectivo de alimentar la mayor capacidad de componentes, sin que se sobre caliente el regulador ya que como usted ha dicho, no tiene un buen disipador de calor.

Mikms

Hola.

La máxima corriente por cada pin es de 40mA, y el máximo es de 200 mA.  PinOut Arduino

Desconozco las conexiones que tienes, y por tanto el consumo que debe tener todo. Pero si necesitas muchas salidas, a reles u otros componentes que tengan un elevado consumo, tienes opciones para tenerlas sin "estresar" al Arduino (que no se si es un Mega o un UNO, ya que primero hablas de un Mega y despues de un UNO, y ni siquiera de que tipo exacto de UNO, etc).

Bueno como te decia puedes tener muchas salidas trabajando, pero para ello no es necesario tenerlas alimentadas directamente si su consumo es elevado, y hay formas de bajar este, dependiendo de que tipo de salida le estés dando a ese pin concreto que queremos hacer que trabaje más descansado, como puede ser mediante transistores, optoacopladores, etc... Pero todo depende de que estés haciendo o que pretendas alimentar.

Por otro lado, como ya te han comentado, alimentar con 12v puedes hacerlo, pero tienes que tener en cuenta que el regulador que tienes es de 5v y no tiene un gran refrigerador conectado, por tanto mientras más te acerques a su tensión de trabajo, menos va a tener que eliminar él para darte esos 5v constantes. Se recomienda de 7 voltios a un máximo de 9 voltios, para evitar eso mismo. Y si necesitas alimentar los componentes externos con esos 12v, y lo estas usando todo con un sólo alimentador, lo que puedes hacer es reducirle con un regulador de tensión (7808 o 7809) y un par de condensadores, la salida correspondiente que va a la alimentación del Arduino. Solamente es una idea, ya que desconozco que tienes realmente conectado etc.

Saludos

tauro0221

Hi,
Si lees el modelo de regulador que tiene la tarjeta de mega ese regulador si buscas las especificaciones dice que te puede dar un una corriente de 1 amperio siempre y cuanod estes usndo lo que se conoce como "heatsink" para que disipe el calor.Si vez el regualdor no tiene heatsink por lo tanto se  calienta. Por eso recomienda de no exceder la coriente de por lo menos 800maax. El mega por regular usa una corriente e 200ma cundo esta en operacion.

Noarodriguez

#5
Feb 10, 2019, 12:21 pm Last Edit: Feb 10, 2019, 06:56 pm by Noarodriguez
Problema, lo he enchufado a la corriente, no se sobre calentaba, iba bien durante unos 15 minutos, he pulsado sin querer el botón de reset, total que he tenido que volver a cargar el programa. Cuando lo he enchufado al puerto USB. Me ha salido esto:


El útimo dispositivo  USB que conectó a este equipo no funcionó a correctamente, y Windows no lo reconoció.

Windows detuvo este dispositivo porque informó de problemas. (Código 43)

Error en una solicitud del descriptor de dispositivo USB.

*

Cuando lo vuelvo a conectar a la fuente la placa funciona. ¿Alguien puede decirme que me ha pasado ahora?

tauro0221

Hi,
Cuando esto sucede lo mejor es leer el voltaje en el mega asi sabras si es que voltaje se caen. Tambien tienes que tener cuidado de estar seguro de que la fuente de energia te puede suplir la corriente. Hay adaptadores de varios tipos de voltajes y corrientes. Lee el voltaje para ver si este es el problema.

Go Up