Go Down

Topic: Arduino uno wifi rev2 can not upload any sketch (Read 1 time) previous topic - next topic

gbafamily

If all else fails, try this link. I do not have the board but have for some devices had to install udev rules. This is covered at the end of the article.

https://majenko.co.uk/blog/diagnosing-arduino-problems-linux



folgorante

If all else fails, try this link. I do not have the board but have for some devices had to install udev rules. This is covered at the end of the article.

https://majenko.co.uk/blog/diagnosing-arduino-problems-linux



Right. SOLVED. Use case:

Problem is reproducible in Linux, tested on Debian 9.8:

  • board Arduino Uno WiFi rev2
  • user already in dialout group
  • access to /dev/ttyACM0 is granted and serial monitor shows arduino output
  • uploading the sketch fails with the following output: avrdude: usbdev_open(): cannot open device: Permission denied avrdude: jtag3_open_common(): Did not find any device matching VID 0x03eb and PID list: 0x2145
  • uploading the code as root succeeds but warns: avrdude: usbdev_open(): WARNING: failed to set configuration 1: Device or resource busy


The problem seems to be the code Upload does not use the serial device /dev/ttyACMx but tries to access directly the USB device. Read write permission must be granted to the user also to direct access to the USB device. The solution pointed out by gbafamily is correct, changes must be done in udev to allow access to USB. If you trust a user group and want to give it access to the USB devices, granting access to all USB devices is a fast hack. This is the code to be executed by root:
Code: [Select]
# echo 'SUBSYSTEM=="usb", MODE="0660", GROUP="insert_your_group"' > /etc/udev/rules.d/00-usb-permissions.rules
# udevadm control --reload-rules

ivanmeneo

Hello again,
I restarted my Fedora 29. Then I tested blink sketch on «Arduino uno wifi rev2» with the same error:

avrdude: usbdev_open(): cannot open device: Permission denied
avrdude: jtag3_open_common(): Did not find any device matching VID 0x03eb and PID list: 0x2145
S'ha produït un error mentre s'enviava el programari.


Thanks for your help.
What can I do ?
Carles.
Hi guys!
I have the same problem with this new brand board. I use Ubuntu 16.04 with 1.8.9 IDE or Hourly version. I tried also with Win7 and Win10, but it was bad too.
Do you think it can be a board hardware problem?
Thanks in advance!
Arduino UNO, Mega, Yun Rev 2, WiFi Rev 2

hatef_8

I have working with this freaking Uno Wifi Rev2 for several hours and still cannot upload a simple blink example into it. I did the same with Uno and it worked, but the same example is not uploading to this freaking borad.
I got sick of this.
there is not enough information found on Arduino website regarding the board and issue. that is the shame!!!

my error by the way:

########################################################
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

pert

still cannot upload a simple blink example into it.
Please do this:
  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to "Show verbose output during: compilation"
  • Check the checkbox next to "Show verbose output during: upload
  • Click "OK"
  • Sketch > Upload
  • After the upload fails, you'll see a button on the right side of the orange bar "Copy error messages" (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.



there is not enough information found on Arduino website regarding the board and issue.
If you have any specific suggestions for how the documentation can be improved, please let us know.

ivanmeneo

Hi guys.
My first problem with this brand new board:
Code: [Select]
avrdude: usbdev_open(): cannot open device: Permission denied
avrdude: jtag3_open_common(): Did not find any device matching VID 0x03eb and PID list: 0x2145
Errore durante il caricamento dello sketch.

Also this after several unuseful attempts:
Code: [Select]
avrdude: usbdev_open(): WARNING: failed to set configuration 1: Device or resource busy
avrdude: WARNING: invalid value for unused bits in fuse "fuse5", should be set to 1 according to datasheet
This behaviour is deprecated and will result in an error in future version
You probably want to use 0xcd instead of 0xc9 (double check with your datasheet first).


Finally, even in the presence of an error:
Code: [Select]
avrdude: usbdev_open(): WARNING: failed to set configuration 1: Device or resource busy,
in my case, it is possible that it will be able to load the sketch but without turning on any led on the board, except for the On of the power supply.
Same thing by pressing the reset button: no light flashes, neither Tx nor Rx.

Also I got sick of this, I sent my board back and the shop refunded me.
But if the reliability problems are solved, I'm sure to buy it again!
Arduino UNO, Mega, Yun Rev 2, WiFi Rev 2

pert

My first problem with this brand new board:
Are you using Linux?

I think the solution to that problem is described farther up in this thread:
https://forum.arduino.cc/index.php?topic=600558.msg4158135#msg4158135
Did you try that?


Go Up