Go Down

Topic: led ws2813 (Read 325 times) previous topic - next topic

sanga

Buongiorno, ho acquistato una striscia led ws2813 e ho collegato correttamente i pin relativi al 5v al gnd e il pin B0 e la striscia funziona correttamente. Tuttavia non so come collegare invece il pin D0.
Vorrei chiedere gentilmente qualche chiarimento a tale pin.
Grazie anticipatamente

gpb01

#1
Mar 02, 2019, 08:50 am Last Edit: Mar 02, 2019, 08:54 am by gpb01
Se guardi il datasheet (allegato) vedrai che devi usare il pin D0 (pin dati del primo LED) per i dati ed il pin B0 (sempre del primo LED) va collegato a GND.

Il fatto che ti funzione ugualmente NON vuol dire che vada bene, dato che in contrasto con il collegamento consigliato dal produttore.

Altro consiglio è, per sicurezza, mettere una resistenza da 330Ω in serie al pin dati collegato ad Arduino.

Guglielmo
Search is Your friend ... or I am Your enemy !

uwefed

Se non arriva segnale a Din prende il segnale Bin.
L'entrata Din é il segnale principale e viene collagato al Dout del precedente o a Arduino se é il primo LED di una striscia.
Bin é un backup se nel caso un WS2813 é rotto e viene collegato a Din del WS precedente. I primi 24 Bit che diopo un reset arrivano vengono scartate perché li avrebbe preso il WS precedente che ora é rotto.

Ciao Uwe

sanga

avrei un'altra domanda per quanto riguarda il collegamento:

Se collego BI in parallelo a DI i primi due led si comportano nello stesso modo,

Se invece collego BI al GND come da manuale il primo led non rispetta assolutamente il codice.

con il tester ho verificato che c'è continuità tra il pin D0 e il punto di saldatura del pin DO e quindi con arduino UNO

ps: sto usando la libreria FastLed

Qualcuno può aiutarmi a capire dove sbaglio?
grazie mille anticipatamente

Go Up