Go Down

Topic: New member here...is this offer legit? (Read 7880 times) previous topic - next topic


Old thread.  New post.  I'd say scam.  It's been 30 days and I've received nothing other than public links to two beyond basic ebooks. No shipping notice, no board, no LEDs, nothing.
I ordered on the 3rd October, received my products this morning. It appears they are a small company (I have had some email contact over the waiting period), who are manufacturing (legally) UNO clones. As said on a previous post, the built-in led is not green. Why didn't they just manufacture it with a green LED, ffs?? I can successfully upload a compiled "sketch" (script), according to the output messages in the Arduino app (I HIGHLY RECOMMEND not installing the Windows Store version of the app, download the XP+ installer...), but no corresponding indication from the board that it is running the code, except for when the upload initiated, one of the two red LED's on the board started blinking rapidly for a second. Some digging, and it appears I need to manually connect an LED to the board - this was not immediately indicated in the instructions. The pack I received may or may not have all the component parts needed to accomplish the task, but I don't know yet, as I have never done hardware/electronics setups before.

TL;DR  I do not think it is a scam. I think they could do with providing better instructions, and while I wait for an email reply, I am convinced they didn't sell me everything I need to complete even the Basic/BLINK sketch/script, specifically resistors and maybe wires....



How long have you been waiting so far for yours? I was considering getting it but not too sure because it could be too good to be true


Hini'm new here. I have receive the uno kit today.


Today (12 November 2019) I have received the board including the advance kits and the mystery gift (50 led light).

The motherboard that I have received is not a 100% genuine product but a cheap clone unit from China. I have tried this board by following the guide (so-called free 2 E-Book) but the problem is the software (Arduino 1.8.10) does not recognize the board.

Is there any expert/professional able to assist me? Because it is not cheap for me to buy this unit and I hope that I can use this board.



See the driver section of the following.

These steps may also save you some unnecessary time and effort in the forum.

  • Always provide as much detail as possible to your issue it may be important.
  • If applicable provide your SKETCH inside CODE TAGS ( </> ) or a CREATE share link.
  • If applicable provide a schematic even if hand drawn.
  • Pictures are an invaluable aid. See THIS TOPIC for help posting them.
  • Check you have a COMMON GROUND where required.
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check your wiring first.
  • Remove any items connected to pins 0 and 1.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • If using CREATE then try and INCOGNITO window or similar to rule out browser add-on's.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE's as ADMINISTRATOR or your OS equivalent
  • If you have tried multiple IDE's then you may need to perform additional clean up.
Performing the above actions may help resolve your problem without further help.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up