Go Down

Topic: Can't upload to Mini 04 (Read 921 times) previous topic - next topic

AndreasR

Apr 25, 2011, 10:40 pm Last Edit: Apr 25, 2011, 10:55 pm by AndreasR Reason: 1
Hello there :)

I am the happy owner of an Arduino MEGA 2560, and i have now purchased an Arduino Mini 04 (new one?) for use in a school project.
With the board i also purchased a USB/Seriel converter to upload sketches with.

I  have a problem, where i cannot upload any sketches to the board. I'm using a button to do the actual reset (see pictures).
The program thinks for a while, then outputs this (held down shift while pressing the upload button):
Quote
avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

        System wide configuration file is "/home/andreas/arduino-0022/hardware/tools/avrdude.conf"
        User configuration file is "/home/andreas/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port            : /dev/ttyUSB0
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:   [20]
avrdude: stk500_getsync(): not in sync: resp=0x20
avrdude: Send: Q [51]   [20]
avrdude: Recv:   [20]
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x20

avrdude done.  Thank you.

This happens under both Ubuntu 10.04 (Netbook edition) and Windows XP SP3

Pictures:
Big picture (You can see the button)


Close up on the board:


If anyone could help with a solution, I'd be greatful :)

vandal

Yeah I can't do it either, I keep getting:

avrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_ReceiveMessage(): timeout
repeating on...

Senso

The reset signal is missing.

AndreasR

Missing as in it's not getting reset? I've tried both with the button and just moving the wire to ground. Both times the LED goes out for a few seconds and then starts blinking again

AndreasR

No one got a solution for this?


Go Up