Go Down

Topic: Sensore stampante (Read 428 times) previous topic - next topic

Kico86

Buongiorno a tutti, dato che mi sono avvicinato da poco ad arduino, volevo chiedervi se potete aiutarmi a capire come collegare un sensore ottico recuperato da una vecchia stampante epson in quanto non vorrei di correre il rischio di bruciarlo ancor prima di usarlo :) invio in allegato il sensore.
Grazie a tutti

gpb01

Prima di tutto, nella sezione in lingua Inglese si può scrivere SOLO in Inglese ... quindi, per favore, la prossima volta presta più attenzione in quale sezione metti i tuoi post ...

... poi, essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie.

Guglielmo

P.S.: Il tuo post è già stato spostato nell'opportuna sezione del forum "Italiano"dove puoi proseguire la discussione.

P.P.S.: Ti ricordo che, purtroppo, fino a quando non sarà fatta la presentazione, nessuno ti potrà rispondere, quindi ti consiglio di farla al più presto. ;)
Search is Your friend ... or I am Your enemy !

gpb01

... ti ho espressamente indicato che il thread è ora già nel posto giusto e che quindi puoi continuare QUI :). Il tuo thread duplicato è stato cancellato.

Guglielmo
Search is Your friend ... or I am Your enemy !

gpb01

#3
Mar 10, 2019, 02:31 pm Last Edit: Mar 10, 2019, 02:31 pm by gpb01
Quello è un sensore IR a barriera ... da un lato c'è un emettitore di IR, dall'altro un LED che li riceve, quando qualche cosa passa in mezzo il fascio si interrompe e hai l'indicazione.

Per capire come connetterlo occorrerebbe sapere il modello esatto e la piedinatura o fare un po' di prove per scoprire quali pin appartengono al LED e quali all'emettitore IR.

Guglielmo
Search is Your friend ... or I am Your enemy !

Kico86

Innanzitutto ringrazio Guglielmo. Ma per fare le prove e per evitare di bruciarlo che resistenze mi consigli con 5v di arduino?

Maurotec

Il connettore sembra avere tre pin, se così i catodi del diodo emettitore e del foto diodo sono connessi assieme, gli altri due sono gli anodi a cui collegare una resistenza per ogni pin. Ora se riesci ad individuare (sembra si possa smontare) i due catodi connessi assieme si evita di fare danni al sensore.

Per il led il problema non sussiste in quanto anche invertendo la polarità non si danneggia, ma per il fotodiodo o foto transistore ci vuole poco a guastarlo.

Ti ricordo che lo smartphon vede gli infrarossi, per cui se il led è IR alimentandolo con un R serie tra 470-1000 ohms dovresti riuscire a vedere il led illuminarsi tramite lo smartphon.

La R per il fototransistor tra 4700 e 10000 ohms.

Ciao.

Kico86

#6
Mar 16, 2019, 12:27 pm Last Edit: Mar 16, 2019, 12:28 pm by Kico86
Grazie Mauro. Allora come giustamente dicevi l ho smontato e ho individuato la pista in comune. Sia il led che il fotores sono uguali all'apparenza. Come faccio a distinguerli? In allegato invio la foto

brunello22

#7
Mar 16, 2019, 04:47 pm Last Edit: Mar 16, 2019, 04:49 pm by brunello22
.


Kico86

#8
Mar 16, 2019, 09:22 pm Last Edit: Mar 16, 2019, 09:23 pm by Kico86
Ciao Brunello, grazie per la risposta però non sono riuscito a risolvere in quanto seguendo il tuo schema il valore che mi appare su serial monitor è sempre 1. Ho sbagliato qualcosa?

brunello22

Di primo acchito direi che dato è senza copertura gli da noia la luce ambiente, ma dovrebbe sempre essere in conduzione (livello LOW )
Ma visto che hai sempre HIGH, il problema è un'altro
O è andato l' Opto, oppure ha un'altro pinout


brunello22

Per scrupolo, dato che ho trovato un paio di Opto smontati da  una Epson ho voluto provarli e confermo che su tutti e due la piedinatura corretta è quella riportata

Maurotec

Anche l'ultima foto a me non alcuna informazione utile, ad intuito potrei dire che il del è quello colorato di rosso, ma non so il perchè per cui siamo punto a capo.

Scegli un sensore e consideralo essere un led, fai i collegamenti e anche quelli del tester o di arduino e poi spegni la luce in stanza. Ora dai alimentazione e con la fotocamere dello smartphon osserva il sensore in questione, se si illumina qualcosa quello è il led, se non si illumina ripeti l'esperimento con l'altro.

Se il fototransistor è al buio non conduce corrente, per cui puoi anche collegarci la R da 470 ohm senza il rischio di guastarlo. Se dopo avere condotto i due esperimenti non ottieni nulla puoi ripetere l'operazione riducendo la R da 470 fino a 220, passando magari per 330.

Se anche così non ottieni nulla, buttalo nella sacchetto della plastica ci hai già perso troppo tempo.

PS: Si sono disturbati dalla luce artificiale prodotto dalle lampade, anche se adesso dovremmo quasi tutti avere delle lampade a led che non dovrebbero emettere altre lunghezze d'onda cosa che invece accade con le incandescenza e con le fluorescenti compatte incluse.

Ciao.

Datman

#12
Mar 17, 2019, 11:15 am Last Edit: Mar 17, 2019, 01:10 pm by Datman
https://www.google.com/search?&tbm=isch&q=transmissive+optical+sensor+epson

https://www.digikey.com/product-detail/en/omron-electronics-inc-emc-div/EE-SX4235A-P2/Z3029-ND/368618

Va alimentato a 5V senza resistenza in serie secondo la piedinatura che vedi nell'immagine. Tra OUT e +5V metti la resistenza di pull-up. Puoi usare quella che si attiva tramite INPUT_PULLUP.

Hi,I'm Gianluca from Roma.I play&work with electronics since I was16(1984).
After 25yrs of maintenance on cameras&video mixers,since 2013myJob is HDTVstudios design.
Since Jan2015 IPlayWith Arduino:bit.ly/2F3LPWP
Thanks 4 a Karma if U like my answer

Kico86

Grazieee Mauro. Ho invertito i collegamenti rispetto a quelli descritti da brunello e voilà. Grazie a tutti, siete grandi.

Go Up