Go Down

Topic: Suddenly not possible to upload to real Nano (Read 423 times) previous topic - next topic

TagCentralen

Feb 19, 2019, 09:32 pm Last Edit: Feb 19, 2019, 09:36 pm by TagCentralen
Hi!

Now I have spent 3 hours on this forum reading topics, using google, reset etc. to get this work.

Any ideas are appreciated, but I understand if it is a tricky question.


Problem:
Suddenly I can not upload from web IDE to the nano.
This has happened 1, maybe 2 times before, but was solved with restarting computer, however that has not worked this time.


Reproduction:
I have any sketch (own or ready made example)
Pressing "Verify" it verifies the sketch.
Pressing "Upload" it begins verifying and then stops with this message:


Code: [Select]
Uploading Ledpwm_statemachine_arbetskopia
./opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware opt/arduino-builder/hardware -hardware ./opt/cores -tools opt/arduino-builder/tools -tools ./opt/tools -built-in-libraries opt/libraries/latest -logger humantags -fqbn arduino:avr:nano:cpu=atmega328 -build-cache /tmp -build-path /tmp/359161443/build -verbose -prefs runtime.tools.avr-gcc.path=./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2 -prefs runtime.tools.avrdude.path=./opt/tools/avrdude/6.0.1-arduino5 -libraries /tmp/359161443/custom -libraries /tmp/359161443/pinned /tmp/359161443/Ledpwm_statemachine_arbetskopia

Using board 'nano' from platform in folder: /home/ubuntu/opt/cores/arduino/avr

Using core 'arduino' from platform in folder: /home/ubuntu/opt/cores/arduino/avr

Detecting libraries used...

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/ubuntu/opt/cores/arduino/avr/cores/arduino -I/home/ubuntu/opt/cores/arduino/avr/variants/eightanaloginputs /tmp/359161443/build/sketch/Ledpwm_statemachine_arbetskopia.ino.cpp -o /dev/null

Generating function prototypes...

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/ubuntu/opt/cores/arduino/avr/cores/arduino -I/home/ubuntu/opt/cores/arduino/avr/variants/eightanaloginputs /tmp/359161443/build/sketch/Ledpwm_statemachine_arbetskopia.ino.cpp -o /tmp/359161443/build/preproc/ctags_target_for_gcc_minus_e.cpp

/home/ubuntu/opt/arduino-builder/tools/ctags/5.8-arduino11/ctags -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives /tmp/359161443/build/preproc/ctags_target_for_gcc_minus_e.cpp

Compiling sketch...

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/home/ubuntu/opt/cores/arduino/avr/cores/arduino -I/home/ubuntu/opt/cores/arduino/avr/variants/eightanaloginputs /tmp/359161443/build/sketch/Ledpwm_statemachine_arbetskopia.ino.cpp -o /tmp/359161443/build/sketch/Ledpwm_statemachine_arbetskopia.ino.cpp.o

Compiling libraries...

Compiling core...

Using precompiled core: /tmp/core/core_arduino_avr_nano_cpu_atmega328_86d814ab5ac6e08f9be464f7f3c7beb3.a

Linking everything together...

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-gcc -w -Os -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.elf /tmp/359161443/build/sketch/Ledpwm_statemachine_arbetskopia.ino.cpp.o /tmp/359161443/build/../../core/core_arduino_avr_nano_cpu_atmega328_86d814ab5ac6e08f9be464f7f3c7beb3.a -L/tmp/359161443/build -lm

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.elf /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.eep

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-objcopy -O ihex -R .eeprom /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.elf /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.hex

./opt/tools/avr-gcc/4.9.2-atmel3.5.3-arduino2/bin/avr-size -A /tmp/359161443/build/Ledpwm_statemachine_arbetskopia.ino.elf

Sketch uses 2958 bytes (9%) of program storage space. Maximum is 30720 bytes.

Global variables use 338 bytes (16%) of dynamic memory, leaving 1710 bytes for local variables. Maximum is 2048 bytes.

Programming with: Serial

Flashing with command:C:/Users/Johan/.arduino-create/arduino/avrdude/6.3.0-arduino9/bin/avrdude.exe -CC:/Users/Johan/.arduino-create/arduino/avrdude/6.3.0-arduino9/etc/avrdude.conf -v -V -patmega328p -carduino -PCOM12 -b57600 -D -Uflash:w:C:/Users/Johan/AppData/Local/Temp/arduino-create-agent584246748/Ledpwm_statemachine_arbetskopia.hex:i

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:/Users/Johan/.arduino-create/arduino/avrdude/6.3.0-arduino9/etc/avrdude.conf"

Using Port : COM12

Using Programmer : arduino

Overriding Baud Rate : 57600


Now is gets stuck in "Busy".



About my stuff
  • I have a true Arduino, bought from Arduino website october 2018.
  • I am using web IDE.
  • Latest Google Chrome.
  • Latest Windows 10.
  • No bluetooth active.
  • Nothing else but an USB mouse and the Arduino connected (I have tried without mouse).



I have tried:
Restart computer
Change cable
Deactivated /activate COM 12.
Restart programs.
Change USB port on computer
Disconnected everything but USB cable

This is what Arduino plugin says:
Code: [Select]
{"Version" : "1.1.81"}
{"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]}
{"Hostname" : "Worldfinder"}
{"OS" : "windows"}
list
{ "Ports": [], "Network": true }
{ "Ports": [ { "Name": "COM12", "SerialNumber": "AC008U9YA", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.81", "NetworkPort": false, "VendorID": "0x040


Anyone have any idea?
Thanks in advance!
/Johan Billow, member of non-profit model railway association "TågCentralen Ljungby, Sweden"

pert

I have confirmed the issue. It seems this is a bug in the Arduino Web Editor. I have reported it to the Arduino developers and I'm sure they'll get it fixed quickly. I'll update this thread if I see that the problem has been fixed.

While you wait, you can use the standard Arduino IDE. You can download it for free here:
http://www.arduino.cc/en/Main/Software

TagCentralen

Thank you Pert, so you say that web IDE doesn't work at all for anyone?

/Johan
/Johan Billow, member of non-profit model railway association "TågCentralen Ljungby, Sweden"

pert

I can say that I did a test and encountered the same problem you did. From that, I would guess the issue is universal, but we only have two data points so far. Note that the issue is limited to people who are trying to upload to new (since 2018) official Nanos. People with old official Nanos, Nano derivatives, or any other board should not have any problem using the Arduino Web Editor.

TagCentralen

Thank you! Maybe it is a problem in W10?

I tried now on desktop program and get this:

Code: [Select]
Arduino:1.8.8 (Windows 10), Kort:"Arduino Nano, ATmega328P"

Sketch uses 930 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
Sketch uses 930 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "\\.\COM12": Åtkomst nekad.


Problem vid uppladdning till brädan. Se http://www.arduino.cc/en/Guide/Troubleshooting#upload för förslag.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
/Johan Billow, member of non-profit model railway association "TågCentralen Ljungby, Sweden"

pert

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

If you don't know which port is your Arduino, you can find it like this:
  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.


If the port is COM12, make sure no other program has that port open. You can only have a port open in one program at a time, so if it's open in a different one, that will block the Arduino IDE from uploading. If you can't find a program that has it open, try restarting your computer. Sometimes there is a glitch that causes a port to get stuck open.

TagCentralen

Thanks I changed USB-port. :) Now we hope they get the web IDE working :)
/Johan Billow, member of non-profit model railway association "TågCentralen Ljungby, Sweden"

pert

The Nano bug in Arduino Web Editor has now been fixed.

WormyOne

#8
Mar 23, 2019, 05:18 pm Last Edit: Mar 23, 2019, 05:19 pm by WormyOne
Hello,  I am currently experiencing the same issue with a Nano clone fresh from China.

(these boards suffer from a missing bootloader issue which I have overcome).  I am able to upload to clone Nano from IDE running Win10, but unable to upload from web, though board is found by agent/web ui.  Note that I AM able to upload to Uno boards from web, so this 'feels' specific to the Nano.

I'd happily ruyn any diags/checks folks might have.  Also, I have read something about Nano clock speed, and this possibly affecting serial baud rate.  Is there  a way to force the web-based toolchain to certain speeds?


ballscrewbob

There isn't really  a way to change much via the web interface.
Are you sure you selected the correct "FLAVOUR" of NANO ?

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

pert

To add to what ballscrewbob said, for the clone Nano, you need to select "ATmega328P (Old Bootloader)" from the "Flavours" menu.

Go Up