Go Down

Topic: Can't get new UNO WiFi Rev2 to connect to (or see) an (Read 809 times) previous topic - next topic

Mayge

My UNO WiFi Rev2 just arrived today and everything seems to be working fine except the wifi. When I run either the ScanNetworks or the ScanNetworksAdvanced sample program, here's the result I get:
Code: [Select]
Scanning available networks...
** Scan Networks **
number of available networks: 0

Scanning available networks...
** Scan Networks **
Couldn't get a WiFi connection

There are at least 3 wifi networks here that it should be able to recognize (2 of which are the 2.4 and 5 GHz networks from my modem). I've also tried turning on my phone's hotspot, which it also fails to recognize. When I try the ConnectWithWPA program, it just says "Attempting to connect" endlessly.
Does anyone know what's wrong here? Am I just making a stupid mistake, or is there something wrong with the board?

redpandaninja

I have the same problem. Once in awhile, it connects to the router, if i upload WPA code to connect.

Go Up